Non-Existent objects in collections inside widgets

What’s The Bug?

There are Non-Existent objects inside my widgets when I expand Collections.

How To Reproduce It

  1. Create a Page
  2. Create a Tree Widget for the Page
  3. Create a Collection inside the Page (not Inner Collection)
  4. Open the Collection and Create an Object inside
  5. Expand the Collection inside the Widget of the Page. The object should appear as expected.
  6. Open the Object, open it’s menu and click “Move to Bin”. The widget is not updated, the Object is still in the Collection.
  7. Open Bin and delete the Object permanently.
  8. Click the Object in the Widget. It will change from it’s original name to “Non-Existent Object”.

There is not way to get rid of it now.

Image or Video

The Expected Behavior

  1. If I move to Bin an object which is inside a Collection, it should not show in the Widget as part of the Collection.
  2. If I permanently delete an Object, remove all the links towards it.

Additional Context

Works just fine on Android.

Device

Asus Zenbook

OS

Windows 11

Anytype Version

0.38

Technical Information

OS version: win32 x64 10.0.22631
App version: 0.38.0
Build number: build on 2024-01-23 17:45:05 +0000 UTC at #c71c64146c6e721ac39e01d450f38db5e6963f2e (dirty)
Library version: v0.30.12
Anytype Identity: ABBupH96mo7XvaYKQdJx47VXbt1XAemHMiCCqBf4A5pQMuVf
Analytics ID: a6fb331b-6fe2-4d5c-8e22-e987e52f8a50
Device ID: 12D3KooWBHfhgwyKgukSssLXRGTs5r4eAL3kGXKJkHfz5uBZetxq

This report has been added to our issue tracker and received by the Development Team.

Is it possible for me to check the progress on it somewhere, or it’s internal to the dev team?

Yes, it’s an internal tracker for the dev team. Sometimes updates will be posted here too.