No way to delete files from the File Type if the file ends up not existing

WHAT IS THE BUG

Unable to delete files from the the File Type.

This also prevents new uploaded files from displaying in the File Type.

HOW TO REPRODUCE IT

  1. Create a new object Relation and limit object Types to “File”

  2. Add the new Relation to a page

  3. Use the newly created Relation and type a non-existent filename (e.g. 40h6j9rjg50) and add it to the relation using the “Create object” feature.

  4. Now if you go to the Library entry of the “File” object, you can see the created file (e.g. 40h6j9rjg50)

  5. If you click on it to open the file it obviously says “File not found”

  6. If you click on the … it does not give you an option to delete the file, nor can you delete it from a File Set

  7. Adding new files using the File/PDF/… Types stops working after having tried to open the non-existent file

In essence, it is creating the “Page” with a “Name”, but not triggering/populating any of the “Relations” in the “Template”.

THE EXPECTED BEHAVIOR

Don’t allow the addition of non-existent files
Allow the deletion of existing and non-existent files

SYSTEM INFORMATION

Macbook Pro 2018
Ventura 13.4
v.0.33.3

ADDITIONAL CONTEXT

There may be a related or unrelated bug (can’t tell as cannot delete these non-existent files) where when using the File Type or Attachment Relation to add a new file, an incorrect filename from another file in that same folder is used instead.

WORKAROUND (BUG LIMITS FUNCTIONALITY)

Please describe a workaround for me to delete these non-existent files so that I can restore functionality. I have an advanced level of computer and software knowledge.

I’ve tried to do a full export (excluding files) and then an import into a clean account, but the same non-existent files persist in the File Type.

Have the same problem on my Windows PC as well

@Eliet thanks for the report, I can replicate on Windows 11 / 0.33.3, sending this to the devs.

p.s. I changed a bit the steps to reproduce the bug to make it simpler for the devs.

Could you please explain this to me before I send it though? I didn’t understand this part

This may be an unrelated problem, but am unable to check that as my account now has the problem.

In essence, when using a Relation to the File Type to upload (not add) a file to a page I noticed:

  1. It sometimes uploads the file, but ends up uploading one with a different name from the folder
  2. Once I have uploaded a file, if I try to upload a different file, I can’t and it continues showing the original file
  3. I’m presuming you should be able to upload multiple files through the one Relation, just like you can add multiple files through the one Relation, but this doesn’t work for uploads, it just uploads a single file which you cannot change thereafter

Could you make a screen recording to show this in action?

1 Like

The same on Ununtu22.04

We really need to see a video of this to accurately reproduce the issue you’re encountering. Then we can forward it to the QA Team.

Thanks!

1 Like

Hey everyone, can we please get an update.