No filtered views without showing relations they filter by

Filtered views are only intact as long as they feature the column representing the relation by which you filter. If you hide (“delete”) it, it deletes the filter.

Steps to reproduce the behavior:

  1. Go to any set
  2. Create a view showing a relation
  3. Filter by this relation
  4. Remove the columns with the filter criteria
  5. Go to a different view
  6. Go back to the filtered view
    The filter is removed now.

I would like the view to remain the same (if I filter all objects of, say, a certain date, I don’t need the date column to be shown because they would all show the same day).

  • OS: Windows 10
  • Device Manufacturer/Model: Microsoft Surface Pro 4
  • Anytype Version: 0.23.5
2 Likes

Hello @hasenrain :wave: I cannot reproduce the issue in Anytype version 0.24.0. I’ve created a filter with a relation which is displayed in the set, after the filter is applied, I’ve removed the relation from the set view and the filter persisted even after switching between multiple views and going back and forth to the set. Do you still face this issue?

Hello @lynxlove, yes - the issue is still there for me! I have tried to filter by a tag relation, as well as checkbox. Should I reinstall and check if this persists?

1 Like

It would indeed be great if you could reinstall and check it again. Make sure you’re on the latest version of the app (currently 0.24.0). If you can reproduce it again, Kindly share a screen recording of the issue to better understand it

Hello lynxlove, I have reinstalled and tried again, it still does not work for me. Recording here: https://ecloud.global/s/erQWPCKyWgFecWD

I can reproduce it now. However, Switching between views persisted the filter, but going back to the dashboard and back into the set removed the filters added on the hidden columns. Thanks for the screen recording

1 Like

Same here! I can still reproduce this on Anytype for Windows 0.25.4.

I’m sorry but if you click Delete - you actually delete relation from set, so basicaly filtering by this relation is not possible because it is deleted. After we implement our new relation storage system we can fix this. So now it is working as intended.

2 Likes