Newly created tags within a relation disapear in SET view

Describe the bug

Newly made tags in a relation seem to randomly disapear from SET view.

Sometimes the tag appears but sometimes it does not, I haven’t been able to find out how to make it more consistent.

Exemple bellow from a SET viewpoint:

  1. creating the tag

  1. trying to add it to another page while still on the SET view

  1. Leaving the SET view and coming back seems to delete it all

  1. It still apears on the page

===================================

Some tags also seem to be able to be created/added on an object but are not visible in set view:

  1. An object with multiple tags within 2 different relations

  1. The same page in SET view with no filters or sorts active

To Reproduce

Steps to reproduce the behavior:

    1. Create a tag within a relation
    1. Try to add it on a new page with the same type/template
    1. Sometimes it is not there

Expected behavior

When you create a tag within a relation it exists until deleted and can be added to other pages with the same relation

Desktop (please complete the following information):

  • OS: Windows 10
  • Device: Desktop
  • Version: 0.18.54
6 Likes

Maybe this is clearer with video :

2021-07-29-07-32-54.mp4

As you can see in this video :

  1. tags are not shown while in set view

  2. some tags are not proposed when trying to add new tags

I’m also experiencing this bug. I created a set of recipes and I wanted to display them in set views.

When I tried to set the filters (by tag) in each view I wasn’t able to view any of the tag I inserted in the recipes (empty list).

Might be related to this: https://community.anytype.io/t/-/1502

We will put it under investigation, thanks!

@HaosGames @quietwalker @Inkqb Logic has been updated in the latest release (0.18.59), please check this issue one more time

1 Like

@Vova it works now! Thanks

1 Like

Solved for me as well, can’t find a single bug witrh tags exept that the “delete option” doesn’t seem to actually delete the tags

1 Like