New Types Not Syncing

WHAT IS THE BUG

Whenever I create a new type, it gets stuck in “preparing…” and never finishes syncing

HOW TO REPRODUCE IT

Outline the steps needed to reproduce the behavior in sequence.

  1. Go to Library
  2. Search for types
  3. Click “create new type”
  4. Notice that the type never syncs

THE EXPECTED BEHAVIOR

I expect the type to eventually sync

SYSTEM INFORMATION

  • OS:
    macOS Ventura 13.1
  • Device:
    M1 Macbook Air 2020
  • Anytype Version:
    Version: 0.30.0

ADDITIONAL CONTEXT

I have created and deleted a few types/relations recently, not sure if that has anything to do with it.

10 Likes

My OS is Fedora Linux 37 and I am also encountering this same problem. I also tried to get the debug log for the relation/object. But it doesn’t work, and no debug log is produced.

I have the same problem
I created few new types on 0.30
They don’t sync and when I close Anytype and reopen, all new types are blank.

Templates created are syncing and new objects of new type are syncing too.
Everything else is blank after reopening Anytype
Name, icon, description, recommended layout reverts to Basic even when it was action before, all relationships are gone
The only thing which stays are templates and created objects are listed.on the bottom of the page

I even tried to recreate everything on both, main computer and laptop at the same time. After closing and opening Anytype all was gone. I thought that this is local stored data first, so why everything is gone from my computers, both of them?

Add images

5 Likes

Exactly the same problem, Windows 11.
In addition, the relation in the set is not synchronized, after restarting the application, the relation in the set is reset, the colors of the tags are also reset.

3 Likes

This report has been added to our issue tracker and received by the Development Team.

4 Likes

@Lubo welcome to the community and thanks for the additional context!

Just wanted to point out that you can take screenshots in Windows with the key combo:

Windows key + Shift ⇧ + S

1 Like

Yeah I know that there is something like that :joy:
I was on discord on mobile so I just took pictures
I even have a video taken by phone, but it was so bad, that I didn’t post it :rofl: