New Types Not Syncing


Whenever I create a new type, it gets stuck in “preparing…” and never finishes syncing


Outline the steps needed to reproduce the behavior in sequence.

  1. Go to Library
  2. Search for types
  3. Click “create new type”
  4. Notice that the type never syncs


I expect the type to eventually sync


  • OS:
    macOS Ventura 13.1
  • Device:
    M1 Macbook Air 2020
  • Anytype Version:
    Version: 0.30.0


I have created and deleted a few types/relations recently, not sure if that has anything to do with it.


My OS is Fedora Linux 37 and I am also encountering this same problem. I also tried to get the debug log for the relation/object. But it doesn’t work, and no debug log is produced.

I have the same problem
I created few new types on 0.30
They don’t sync and when I close Anytype and reopen, all new types are blank.

Templates created are syncing and new objects of new type are syncing too.
Everything else is blank after reopening Anytype
Name, icon, description, recommended layout reverts to Basic even when it was action before, all relationships are gone
The only thing which stays are templates and created objects are listed.on the bottom of the page

I even tried to recreate everything on both, main computer and laptop at the same time. After closing and opening Anytype all was gone. I thought that this is local stored data first, so why everything is gone from my computers, both of them?

Add images


Exactly the same problem, Windows 11.
In addition, the relation in the set is not synchronized, after restarting the application, the relation in the set is reset, the colors of the tags are also reset.


This report has been added to our issue tracker and received by the Development Team.


@Lubo welcome to the community and thanks for the additional context!

Just wanted to point out that you can take screenshots in Windows with the key combo:

Windows key + Shift ⇧ + S

1 Like

Yeah I know that there is something like that :joy:
I was on discord on mobile so I just took pictures
I even have a video taken by phone, but it was so bad, that I didn’t post it :rofl:

This problem seems to have been fixed by version 0.31.0.

1 Like

@firebert is this also resolved for you?

1 Like

I was having the same problem and now it is solved for me (Anytype 0.31.0, OS Windows 10).
Types and Relationships can be customized, created and synchronized correctly.
All are maintained after restarting the application or the operating system. None disappear.

It seems to be resolved. Though I am seeing a different issue where the type or note appears to be synced on my desktop but then doesn’t appear or appears incorrectly on ios. Ex. created a new type to test this out and then a new note using that type. I opened the mobile app and found that note and it says it’s a “deleted type”

1 Like

If it’s OK for you, I’ll mark this one as resolved. Could you search the forum for existing topics for the other/new issue? You can flag this topic if you want it to be reopened.

I’m having the same problem explained by @firebert

However, in my case there are a few subtle differences:

  • When I create a new Type (e.g., “NewType”), the sync indicator is stuck in “Preparing…”, HOWEVER the new type is actually being synced in about 30 seconds (I’m making sure by checking from my Android device with the app installed)
  • However, If I don’t wait enough from my Android device, all objects of type “NewType” appear with a text in red saying “Type deleted” or something like that.

I have the same problem here.
I created the type: “Plan” on the desktop client, but it’s not synced to mobile.