New object from template does not show relations

Describe the bug

I have a template for a custom type. When i click ‘+’ icon in the home view and select my custom type the relations are not displayed as per the template. Instead they are showing some placeholder which says ‘New Relation’ for every relation included in the template. But if i close the newly created object and reopen it then the relations are displayed correctly.

To Reproduce

  • Create a custom type and add a few custom relations to it.
  • Create a template for it which includes the relations.
  • Then go to the home screen and click the ‘+’ button and select this custom type.
  • The new object page will open with the relations not displayed as per the templated
  • Close the object and reopen and you will see the relations

Expected behavior

When the new object is created as per the template the relations need to be displayed.

Desktop (please complete the following information):

  • OS: Mac OS 11.4
  • Device: MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
  • Version: 0.18.59

Additional context

na

7 Likes

Describe the bug

Custom type template is populated with two relations: Issue and Main Contact.

The relations don’t populate correctly when creating a new object.
new-object-error.mp4

To Reproduce

Steps to reproduce the behavior:

    1. Create a new type
    1. Add new relations to the type
    1. Create a template with the new relations included as blocks
    1. Create a new object from the home screen (+ button near profile picture)

Expected behavior

I expect the new object to produce the relations which have been set-up in the selected template.

Desktop (please complete the following information):

  • OS: macOS 11.5.2
  • Device: Mac mini
  • Version: 0.18.59
1 Like

Can you please check if your issue is the same as the one in this report?

https://community.anytype.io/t/-/1589

2 Likes

@lynxlove you’re absolutely right. This is the same error. @Oshyan can you please merge the two tickets? Sorry!

I consistently experience this same bug on two different machines (a Windows 10 and a Windows 11), but with the following quirk, which might be helpful to know about if @ratiocinate experiences it the same way:

  • When selecting Create ->New Object from a Type view, the template’s displayed relations appear correctly.
  • When selecting the + button in a Set view, the relations appear correctly.
  • When selecting the home screen’s + button, the bug described in the original post occurs. But if I immediately close the object and re-open it, I see that the relations actually are now correct and normal – they just initially displayed as “New Relation.”
  • When creating an object by typing @ and entering a non-existent name, the same bug occurs.

So is there something different about how objects are created in the latter two cases?

It has been fixed, see in the next release

2 Likes

@Kirill_Lem, was this corrected at a later release than 0.19.0?

For me this is still happening.

To Reproduce

    1. Create a new type
    1. Create a new relation of the kind Object (relation A)
    1. Create a template

4 . Inside the template, create a new relation from scratch of the kind Object (relation B)

    1. From home page, create a new object, without setting its type
    1. Type “@” to create a mention, and instead of choosing an existing object, create a new object
    1. Click at the mention to open the object
    1. Set the object type the same as the type created at step 1
    1. When the object opens, the relation A does not show up with its correct name, but as “New relation”
    1. Closing the page and opening it again, the relation A appears with its correct name

System Information:

  • OS: Windows 8.1
  • Anytype Version: e.g. 0.19.0
1 Like

@thiago_nascimentodf does it still happen for you in the latest release?

Yes, it still happens in version 0.21.5.

To reproduce:

  1. Create a new type.
  2. On this newly created type, add a new relation (“relation A”) of the kind Object.
  3. Still on this type, create a template.
  4. From home page, create a new object and select the newly created type.
  5. In the newly created object’s page, type /relations and add “relation A” by clicking on it.
  6. "relation A" does not show up with its correct name, but as “New relation”.
  7. On reopening the page, “relation A” shows the correct name.
2 Likes

I’m also still experiencing this bug - version 0.21.9 on Linux

Hi there, the bug is still happening on windows 10, Anytype version 0.23.5.

Guess it’s the same thing, except for not all relations aren’t shown.

1 Like

Just tried it on Windows with 0.24.0 and my relations are displayed fine.
Please check if this bug still occurs to you.

I am experiencing this same bug on Windows 11, Anytype 0.25.4