New bookmarks not being added to Bookmarks collection

WHAT IS THE BUG

When I want to add a new bookmark to my bookmarks collection, when pressing on New and then pasting the URL, it just doesn’t do nothing.

HOW TO REPRODUCE IT

  1. Go to a Bookmarks collection.
  2. Click on New.
  3. Copy the URL.
  4. Nothing happens.

THE EXPECTED BEHAVIOR

The bookmark should be added as usual to the bookmars collection.

SYSTEM INFORMATION

  • OS:
    win32 x64 10.0.19045
  • Anytype Version:
    v.0.35.15-beta

Can’t replicate in 0.35.15-beta on Windows 11 23H2.

:thinking: I have only Set with bookmark object type and everything works well. I try to create collection and add to it new objects with “Bookmark” type - and I can’t create it like in Set (pasting a link)

Okay, now I get it.

I just realized that I can’t insert new bookmarks in the collection because I already have it in another page (I have set the bookmark as /bookmark in a page object).

What I am looking for then is to make a Set of bookmarks and not a collection, because I want all the bookmarks of all the different pages to be centralized in a Set (in this case “Bookmarks list”).

Thanks @PavloUA for the answer and sorry for the misunderstanding.

You can actually:

  • Create collection
  • Set default type to Bookmark
  • Create new bookmark with + New button
  • Open it, paste your URL into source relation and click Reload from source

it’s a bit longer, but it works. This limitation is because collection interface doesn’t show the bookmark menu.

1 Like

I will try to use this method from now on.

Thanks @Razor

Have a good day!