My Object is Broken!

Describe the bug
I reinstalled Anytype on Windows to continue my work on a specific object after using Anytpe not for a while. I fast realized that something didn’t work as usual. I couldn’t delete blocks or create some new. I almost couldn’t make any changes at all. Somehow I managed to move a block and paste a bookmark and made some toggle blocks, but then the object totally gave up. Now I can’t open the object anymore. It does load forever. Clearing the cache or reinstall Anytype doesn’t work either. So I thought fine I will use my phone to clear things a bit up but it’s the same story, unfortunately… I can’t make any changes. Now I’m stuck with a loading screen on Windows and android and can’t access the object at all. The object only had about 50-100 blocks. Has someone an idea how I can fix that ???

To Reproduce
I dont know how to reproduce it. I just installed Anytype and opened the object and tried to make some changes.

Expected behavior
My object should be normally working. Not stuck on an endless loading screen, able to make changes etc.

System Information:

  • Android 11 on Samsung Galaxy S20 FE and Windows 11 both with the latest Anytype versions 0.25.4 on Windows and 0.6.1 on Android

The file is only 19mb but the forum says its to big okay so here I reproduced how I made my Anytype unresponsive and corrupted my object so that I cant use it anymore on any device.

1 Like

Hey! We are on it. We will provide you with more details during the investigation

1 Like

Thanks! The object is still syncing/unusable unfortunately.

Any update on this? I tried to reproduce my work but again some bugs making it almost impossible to work right now in Anytype. I couldn’t use the “undo” button when something happened. Just checking on some object histories changed my object completely without even accepting the change. Now I lost some work again and my current version is now a mix of an older version and some things I just wrote? The object is now at a critical stage again where I guess it’s only a matter of time until this one is also completely unusable. I just worked with toggle blocks, bullet lists, line divider and align center. As soon as I start to duplicate or moving some toggle blocks, things got messy. Some blocks are not changeable anymore. I can’t mark them, move them, delete them etc. it’s all stuck.

1 Like

Hey @XxxBalCion

Sorry for the delay, we haven’t forgotten about you. Hang tight, we will be back with an answer ASAP.
@requilence @eugene @mordan @Razor Can you help us out here?

1 Like

@XxxBalCion The Go Team is trouble-shooting your problem now. Can you try updating to the latest version and then attempt to delete & modify?

I tried to delete the object on Windows 0.26.1. It disappeared, but didn’t show up in the bin. I can’t “undo” or “restore to a previous version” to make it show up again. I can still find it though when I use the normal object search. Before I deleted it, I tried to open it again. Then I’m stuck on a loading screen and my PC fans getting very loud, which usually never happens when using Anytype. On the latest Anytype Android version 0.8.2 its stuck syncing.


Like I mentioned before, this is how the object became unusable: When I duplicated toggle blocks (bug occurred) and moved some blocks (bug occurred) the object performance began drastically to slow down. I kept going, duplicated things until the object then gave up working : (

1 Like

Ok, thanks I’ll share your response with Go Team

1 Like

@XxxBalCion It seems like the bug in version 0.25.4 produced the huge document with a ton of nested blocks and the desktop client can’t handle it. On the middleware side, this document also broke the deletion mechanism due to a rare bug that requires further complex investigation. We are still looking into it, but the screenshot being cropped liked this gives us limited insight.

Some requests from our Devs:

  • Can you please share a pic which reflects that Anytype is the culprit, and include RAM, CPU usage, etc?

  • What percent is used by Anytype and which process? (There different processes for render and middleware in Windows)

  • Is everything else in Anytype behaving as expected?

Thanks and awaiting your reply.

Sorry, that file is too big (maximum size is 1000 MB).
The file is only 32,3 mb. I will upload it via Google Drive here.
Anytype takes about 10 percent of my CPU usage. It doesn’t seem much. I use a Ryzen 3700x. The fans I recognized spinning this time were my graphics card because of my screen recording.
About your last question, I have a bunch of objects which never sync since months, maybe even a year. No matter how many times I reinstall Anytype on android or windows.

Being able to use those object again would also be great!

@XxxBalCion Thank you again for your endurance with us while we work to resolve this problem; for now, we’ve tried everything we can do. It looks like your document was broken in an old version of Anytype due to a collision of undefined bugs in an experimental feature, which compounded each other and spun out of control. A huge amount of work has been done to investigate this and the good news is the bug is not reproducible in the latest versions. Specific to your case, the next Desktop release may fix your document, but we can’t be 100% sure until you try, so it would be super helpful for us if you can report back after the update. We’re very sorry this has occurred and would like to emphasize that your contribution as a tester is absolutely essential for us to prevent recurrences of situations like yours. :pray:

1 Like

Thank you for your effort I highly appreciate it!:pray: Let’s hope the next update will fix it : ) I will let you know if it worked as soon as I tested it.

2 Likes

The update didn’t fix my object, unfortunately. It’s still loading. A fresh installation on windows didn’t help. I also did a fresh installation on android and I could open the object for a while : D I tried to move my important stuff/blocks to another object but it didn’t work. After leaving the object, I couldn’t open it again. I guess that’s it, then. I appreciate your effort trying to fix it!

1 Like

Is there any way to delete a corrupt object? Without being able to open it, I cant delete it as it seems…
The delete option on the photo only deletes the linked object, but not the object itself.

Another option to delete an object would be via set.
Screenshot 2022-09-20 015438
But I still can’t delete it. The object don’t move to the bin. Is there any way to help me delete it, or am I stuck with it forever now : D ?

Never mind, after a restart it moved to the bin. Guess this topic can be closed then.