Missing checkbox filter

Describe the bug

When creating a set that consists of objects with the layout type “Action” the “Done” filter is missing.

The easiest way to show this is when creating a set of the type “Task”, you can filter out objects that have the checkbox checked:

Where if I create a new set of objects using the layout type: “Action” the “Done” filter is missing:

This might just be me not being able to figure it out tho :sweat_smile:

To Reproduce

Steps to reproduce the behavior:

    1. Create a set of objects that are using the layout type “Action”.
    1. Open filters on the current page in the set.
    1. Unable to locate filter “Done”.

Expected behavior

When using objects with the layout type “Action”, I would like to be able to filter objects based on checkbox status.

System Information:

  • OS: Windows 10
  • Device Manufacturer/Model: Desktop
  • Anytype Version: 0.20.9

Additional context

I checked out the setup/relations of type: “Task” to see if I could find anything that would enable the “Done” filter, but was unable to find anything. Also tried making a relation with the relation type: “Checkbox”, but that would just add an extra checkbox to the object.

1 Like

+1. I have the same problem.

I opened Anytype this morning and the Done filter is back. :person_shrugging:

Hey @Cernel1337 :wave: All of my sets have the Done relation as an option to select in it’s filter? Can you still reproduce this issue with the latest version of Anytype(0.24.0)?

Hi @lynxlove
The issue has been resolved as of Anytype version 0.24.0 :slight_smile: