Mentioning/Linking to a page not working

Describe the bug

When I want to mention a page, it creates an entirely new page and doesn’t give me options of any existing ones.

To Reproduce

Steps to reproduce the behavior:

    1. Create a new block
    1. Write the “@” symbol

Expected behavior

It should prompt you to mention a page but the white card that pops up is empty and when you write the name of a page that exists, it creates an entirely new page.

Desktop (please complete the following information):

  • OS: Windows 10
  • Version: 0.16.8

I cannot reproduce it on Windows 10, Anytype 0.16.8.

For your information, typing @page_name and hitting enter will not directly mention a page; in fact, it will create a new page with the name you entered just as you described. If you do not hit enter yet, it will bring up a list of pages whose names match with the keyword you entered. Then you will need to either click the page you want to mention or use the arrow keys to go down and select a page. See the image below and notice how my current selection has a gray overlay.

That is also what I expect to happen on my end but no suggestions ever pop up. The card only displays the option to create a new page

For context:

[Here](https://photos.app.goo.gl/P61CWckYL2ebRFAXA)

Tested it out on android and it works but desktop is still not working for me

This bug report can be discarded.

@BGray I suppose your problem is linked with indexing issues, that we are going to solve in the next release.

@Mukanzi I’ve reproduced your problem and it will be fixed also.