Markdown "highlighted" doesnt show characters before the animation ends

Describe the bug
When using markdown to make a “highlighted” block and typing a bit faster, not all typed characters are written into the highlighted block, because it seems, that the animation of the block has to be finished, before input is taken.

To Reproduce
Steps to reproduce the behavior:

  1. Typing (a bit faster) this a " symbold plus space and then some text
  2. At least the first character isnt shown

Expected behavior
Take all input and show it.

System Information:

  • OS: Linux
  • Anytype Version: 0.21.9

Additional context
In the video after typing " plus space I instantly type three times “t”. One is missing.

1 Like

@Flip Hi! I was trying to reproduce it, but I can’t. Do you use other apps while working with Anytype? If yes, does anytype works slower when you have several working programs or it doesn’t matter?

Hey, I did not notice any performance differences.
Are you fast enough :sweat_smile: ?

@Flip I think enough) So, I continue to dig this problem

@Kirill_Lem If I can somehow help you, let me know.

Hi @Flip
I can’t reproduce it as well.
Are you able to do it repeatedly? Or it happens once in a while?
Also, Can you reproduce it again with few apps open and background like heavy software? And reproduce without them as well?

OS: Linux
Version: 0.21.9

Linux and performance issues are my forte :joy: I can easily reproduce this issue. In fact, I always faced this issue in any type of block (not only Highlight) since the beginning of me using Anytype

Not just this, I face several other performance issues with my hardware on linux :frowning_face: (Haven’t tried the same with windows in the same hardware but I can if the team wants to test something)

  • Slow startup
  • Enter / Tab / Backspace key slowness issue
  • Page opening / creation delays
  • Adding or removing block delays
1 Like

That delay in the video is crazy.
Mine is less than a half a second I would say.

I would also say that I don’t have huge delays in the other things you described, but I only use it on Linux so I have no comparison.

Wow, that delay is insane!! How do you manage it? Also, what are your hardware specs?

You can find my hardware specs in the following report.

I’m used to the delay since it happens for any block that I try to create. But it would be great if the app is optimized for slower hardware as well

Have you already tried to use Anytype on another OS with these hardware specs?

@Kirill_Lem But yeah, what lynxlove demonstrated is exactly the problem I faced. Just not that extremely.

Nope, in order to install Windows, I’ve to re-partition the drive to make space for it. I’ll try it next week though. I’m eager to know if it changes anything as well

1 Like

Or maybe if its just for testing, Install it on a seperat disk.

1 Like

I had some free time today and tried Anytype on a Windows VM with Gnome Boxes
Ram allocated for VM: 4.4 GB
Disk Space: ~80GB
CPU: 4

I’m surprised to see Anytype perform better on the VM than on the host

1 Like

I can still reproduce it.
Here I typed “test” faster after pressing enter on the “highlight” block.

Related:

This issue has been added to our issue tracker and was received by the Development Team.