Make "Create Set" more visible

Is your feature request related to a problem? Please describe.

Multiple new user (including me) are searching, where to create a set. So it seems to be not intuitive enough to create one.

Describe the solution you’d like

Two ideas.

    1. Create a second button (red).
    1. Create a little arrow with a dropdown (blue). This maybe only practial, when there are more options coming, that can be added to the dropdown.

23 Likes

Working on it :slight_smile:

5 Likes

and…how do you create a set? (new user here). I saw you guys doing it in the onboarding but I can’t find it anywhere now…

@nfcf Go to the Type you want to create a set, Press the create button and it would show you the option to create a set of that type

@lynxlove perfect, thanks! and apologies for the newb question

Shouldn’t it be possible to create a Set not limited to a single Type?

Quoting myself from elsewhere:

https://community.anytype.io/t/-/1700

2 Likes

I was on a shared-screen call with a friend showing off AnyType and spent about 20 minutes trying to show him how to create a Set out of a couple of Contacts. I still don’t know how.

Some things I tried:

  • Cmd+N then Create a “Contacts” object of type Set (there is no Set type listed)
  • Go to the “Sets” main page section and look for a “New Set” or “Plus” button (none found)
  • Go to a Contact (the object whose type I want to create a Set Of) and check the corner hamburger menu for “Create Set” (no option)
  • Add a “Set Of” Relation to the Contact (this seems to be the opposite relation from the one I want)

Anyway, you probably get the point. I tried a bunch of things but was unsuccessful.

3 Likes

I was about to write the same post, making a set is very unintuitive and not very flexible… You can’t adjust relations for example and adding relations is not easy, specially when you have already added a lot of pages to the set.

Part because of the UI and part of how sets/relations/types work in Anytype. Well, guess it is an Alpha for a reason. :wink:

How to make a set is as follows:

    1. Click on the button in the top right next to your profile (the rounded square button)
    1. Click on Types, then click on the type which you want to make a set
    1. Now when in this type page, click on the orange Create button in the top right
    1. Then click on the New Set of Objects from the pop-up menu

Congrats, you have no created a new set.

Maybe upvote here:

https://community.anytype.io/t/-/1604

Glad it’s being worked on! Thanks anytype crew.

I hope we fixed that in the latest release!

Hey,
just to get it right.
We now can use the “Set” object directly to create a set, because in there we can change the “source” of objects.
And the “Create” button in the store for “Set” was removed.
Was there anything else changed?