Login problems with Android, now Windows

Describe the bug

I signed up for my Anytype account from the Windows desktop app and my first problem was that it did not allow me to login from my Android devices for a few days. It kept getting stuck at fetching. I talked about this with @Evgenii over Telegram and, after a while of “failed to find any local o remote accounts derived from this mnemonic” it was solved eventually. However the test content I created in Windows did not get through to Android, and whatever I added in Android did not show up in Windows either (I assumed no sync). Once the logging in problem was solved, Android devices (smartphone/tablet) synced just fine from one another.

As per @Evgenii -s advice, I checked https://community.anytype.io/d/20-known-problems and followed the steps there, thus logging out from everywhere and even reinstalling just in case. Android devices went back just fine (to show up only the content I created in Android), but now my Windows desktop app does not log in and returns this error message:

To Reproduce

Just tried to login from the Android app into an account I created through the Windows desktop app. After logout from desktop, I can’t log back in.

Expected behavior

I would expect to login through both the Windows desktop and Android apps and see the same content everywhere.

Desktop (please complete the following information):

  • OS: Windows 10 Pro, 1909, 18363.900
  • Device: Windows Laptop
  • Version: 0.16.8

Additional context

– (I couldn’t see how to add tags to this bug report, sorry)

OK, I respond to myself.

It occurred to me while I was writing the bug report that my laptop/Windows desktop app is behind a corporate firewall in my workplace. Just tried again sharing my mobile network and logged in OK, to see only the content I created through my Android devices.

I assume whatever I created in the Windows desktop app is lost, and never synced – because of the corporate network settings. I guess the first thing here is then to identify and somehow notify these sync (to the server) issues to the user. It never occurred to me that the app was unable to sync. Which is weird on the other hand, because the account was created somehow. Or did this actually happen only after I logged in from Android (which does sync with the servers), and everything I did on Windows happened only in my local machine? Maybe that is why Android was unable to fetch anything from that mnemonic – because it didn’t exist in the server?

Let me know if I can give you further details to help solve this. Thanks!

Resurrecting this old report because I can confirm that I’m having something similar to @miren: when trying to login behind a corporate firewall I get an error:

failed to fetch remote accounts derived from this mnemonic: failed to get auth code
rpc error: code = Unavailable desc = transport is closing

Unlike the OP, switching to wifi isn’t a solution for me because we run a “cloud-based firewall” that is active on every network.

This is normally not an issue: it’s actually pretty transparent most of the time. There is one critical detail though–our firewall does SSL/TLS interception as part of an overall data loss prevention strategy, meaning that my company has its own root certificate that Anytype doesn’t know about, so to Anytype the cert trust chain is broken.

The preferred solution would be to have a way to add additional trusted certs to whatever cert store Anytype uses. The less-preferred solution would be an option to ignore the error (after an appropriate warning).

I realize this is likely a very low priority at the moment, but it is a bit of a show-stopper for my (and I’m guessing, at lot of corporate) use; so bringing this back up to make the developers aware.

2 Likes