Linux desktop app only showing menu bar and blank screen

The real problem

Anytype requires GLIB to be 2.31 or higher.

Debian 10 current version is 2.28.

To check your version :

$ ldd --version
ldd (Debian GLIBC 2.28-10) 2.28

Resolution

Upgrading your GLIB version is NOT RECOMMENDED.

It is possible to upgrade it via the Debian 11 Bullseye repos but GLIB is part of the core and this could mess your system up.

Best solution is probably to :

  • upgrade to Debian 11 if it makes sense for you
  • run Debian 11 in a VM if you only need it to use Anytype

Describe the bug

When starting the application, it only displays a grey menu bar and a blank screen.

From there, nothing can be done (none of the menu items seems to display anything).

To Reproduce

Steps to reproduce the behavior:

Expected behavior

The application should open on the home screen.

Clicking menu bar items should change what is displayed.

System Information:

  • OS: Debian 10 (Buster), Desktop Manager: Gnome 3.30.2 (system is up-to-date)
  • Device: ThinkPad T470 W10DG
  • Anytype Version: 0.19.0

Additional context

The “solved” post you linked has a comment about glib version, you may want to check it against the version you have.

1 Like

@BGray

Oh, my bad, I misread the comment in the Solved post.

My GLIB version is 2.28 and 2.29 is required, I read 2.19the first time 🤦

Thanks for sending me back to the solution !

I’ll edit my original post.

I got the same bahaviour, but using a different lisnux distro (Fedora Silverblue 34 on wayland).

Mine happens every time I let Anytype window opened for a long time, namely when I let it open at night and come back at the morning.

Additionally, I need to kill the process (e.g. via terminal) in order to close the app. When I relaunch it, it works out fine again.

It does repro on Windows Desktop app as well, it’s definitely not solved

Windows 10, Anytype 0.20.9.

It seems to happen when Anytype is left by itself for a little, or if I lock my screen. It could be that it’s the “left by itself idle” condition that I see, no matter if the screen is locked or not though.

I actually found another bug listing this issue: https://community.anytype.io/t/-/1347

I too get a blank screen with only menu bar showing, and no prompt to log in.

This happens everytime I boot into Wayland/linux, but if I instead choose X11/linux on the same machine, then everything is working as it should.

I’m on:

  • Anytype 0.20.9
  • Opensuse, tumbleweed
  • KDE

I now got Anytype to work on Wayland. Don’t know why it works now, probably because of upgrading my OS and/or Anytype to a newer version.

Is this still happening to someone of you?