Just downloaded, open to blank screen

Describe the bug
Just downloaded Anytype from the website (Mac desktop). I open it and it’s just a blank screen. I can’t even view “about” - also a blank screen.

To Reproduce
Steps to reproduce the behavior:

  1. Download Mac desktop version
  2. Open it
  3. It shows a blank screen

Expected behavior
I expect not a blank screen

System Information:

  • OS: MacOS Monterrey 12.0.1
  • Device Manufacturer/Model: Apple (macbook pro M1)
  • Anytype Version: doesn’t show, it’s blank

Additional context
Add any other context about the problem here.

Can you try re-opening the app after force quitting it? Few reported that doing that solves the issue in few tries

I did. It still doesn’t work. I’m uninstalling.

I can confirm this happened to me today, and I am no longer able to use Anytype at the moment. Which impacts my work, unfortunately. Please advise on the next steps.

App version 0.23.5, on Apple M1 Desktop.
Force quitting or reinstalling doesn’t work.
Corrupted configuration/user file?

Tried to run with --disable-gpu as well but it didn’t help:

20:02:45.092 › Config: {
   "channel": "latest",
   "theme": "dark"
}
Channel:  latest
native addon init
mw jsaddon: v0.17.24
(node:9478) UnhandledPromiseRejectionWarning: Error: An object could not be cloned.
    at EventEmitter.t.ipcRendererInternal.send (node:electron/js2c/renderer_init:85:328)
    at EventEmitter.<anonymous> (node:electron/js2c/renderer_init:81:357)
(Use `Anytype --trace-warnings ...` to show where the warning was created)
(node:9478) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 1)
2022/02/15 20:02:49 Assert failed
github.com/dgraph-io/badger/y.AssertTrue
	/Users/runner/go/pkg/mod/github.com/dgraph-io/badger@v1.6.2/y/error.go:55
github.com/dgraph-io/badger/y.CompareKeys
	/Users/runner/go/pkg/mod/github.com/dgraph-io/badger@v1.6.2/y/y.go:129
github.com/dgraph-io/badger.(*levelHandler).initTables.func2
	/Users/runner/go/pkg/mod/github.com/dgraph-io/badger@v1.6.2/level_handler.go:72
sort.medianOfThree_func
	/Users/runner/hostedtoolcache/go/1.17.3/x64/src/sort/zfuncversion.go:56
sort.doPivot_func
	/Users/runner/hostedtoolcache/go/1.17.3/x64/src/sort/zfuncversion.go:80
sort.quickSort_func
	/Users/runner/hostedtoolcache/go/1.17.3/x64/src/sort/zfuncversion.go:143
sort.Slice
	/Users/runner/hostedtoolcache/go/1.17.3/x64/src/sort/slice.go:20
github.com/dgraph-io/badger.(*levelHandler).initTables
	/Users/runner/go/pkg/mod/github.com/dgraph-io/badger@v1.6.2/level_handler.go:71
github.com/dgraph-io/badger.newLevelsController
	/Users/runner/go/pkg/mod/github.com/dgraph-io/badger@v1.6.2/levels.go:178
github.com/dgraph-io/badger.Open
	/Users/runner/go/pkg/mod/github.com/dgraph-io/badger@v1.6.2/db.go:297
github.com/ipfs/go-ds-badger.NewDatastore
	/Users/runner/go/pkg/mod/github.com/ipfs/go-ds-badger@v0.2.7/datastore.go:156
github.com/anytypeio/go-anytype-middleware/pkg/lib/datastore/clientds.(*clientds).Run
	/Users/runner/work/go-anytype-middleware/go-anytype-middleware/pkg/lib/datastore/clientds/clientds.go:129
github.com/anytypeio/go-anytype-middleware/app.(*App).Start
	/Users/runner/work/go-anytype-middleware/go-anytype-middleware/app/app.go:163
github.com/anytypeio/go-anytype-middleware/core/anytype.StartNewApp
	/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/anytype/bootstrap.go:77
github.com/anytypeio/go-anytype-middleware/core.(*Middleware).AccountSelect
	/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/account.go:477
github.com/anytypeio/go-anytype-middleware/clientlibrary/service.AccountSelect
	/Users/runner/work/go-anytype-middleware/go-anytype-middleware/clientlibrary/service/service.pb.go:652
github.com/anytypeio/go-anytype-middleware/clientlibrary/service.CommandAsync.func1
	/Users/runner/work/go-anytype-middleware/go-anytype-middleware/clientlibrary/service/service.pb.go:3367
runtime.goexit
	/Users/runner/hostedtoolcache/go/1.17.3/x64/src/runtime/asm_arm64.s:1133
1 Like

Yes, I can also confirm that the same issue happened to my installation. Fortunately, clearing the work directory and logging back in with my keychain phrase did successfully get the app working.

I’m also on a M1 MacBook Air - using the native arm64 app.

1 Like

Thank you for the information @edwards. Could you advise on how to clear the working directory? Does it induce any data loss?

It definitely sounds like a corrupted file. I will backup mine before doing the procedure, in case there is indeed a corrupted file that can be recovered for further analysis for the devs to fix it.

1 Like

I was able to find an article explaining all that, for future users hitting this:

Did you manage to find the solution to clearing the work directory in the help article? Hopefully no data was lost!

Yes, thought it’s not a “solution”. This still needs to be addressed. This time the data folder was already 7GB. I can’t imagine having to download that again next time when it’ll be much bigger.

To the devs: I have a backup of my anytype2 folder if you guys need me to inspect anything.

1 Like

Yes - I agree, it took me a hour or so to get everything synced from the backup node! This issue needs to be looked into and resolved as soon as possible.

@edwards @nelatmani here was some hiccup with high system utilisation on our end. the team is working to fix resource cpu utilisation and outgoing packets on the backup node which are affecting the sync. there has been a temporary fix and the permanent fix is incoming

2 Likes

Appreciate the reply, thanks!

Just a question - does that mean the issue is client-side or server-side? I’ve experienced my second crashed profile folder from this issue, and that was a bit after this post.

This still repro and is very painful to temporarily fix. Any update on this?
This happened while the application was largely idle this time so I would think no sync was necessary.

Mainly, is there a way to know which file gets corrupted, so that we can force a sync of this file only?
My folder is about 7GB+ I can’t delete it and re-download everything like that every time. Even for the backup node, this doesn’t sound good.

Thanks

1 Like

This happened to me for the third time in the last two months. All three occurences happened when the computer was idle, but it appears that deleting the anytype2/Cache directory did resolve it for my case- no need to delete the entire work directory and resync everything.

1 Like