Item cannot be archived

Describe the bug

I cannot archive a certain draft item in the Windows app.

To Reproduce

Steps to reproduce the behavior:

    1. Go to ‘Inbox’
    1. Click on ‘…’ on the item, then ‘Move to archive’
    1. The item just stays there.

I also tried to change the type to ‘Document’ and then archive the item but this does not work either. I think the item was initially imported from Notion. For most of the other items archiving works just fine.

Interestingly I cannot find the item on the Android device. So, I guess it is just a local copy on the Windows machine.

I can see the behavior for just two items, so it is hard to reproduce if you don’t see it at all.

Expected behavior

The option ‘Move to archive’ should move the item to the archive.

System Information:

  • OS: Windows 10

  • Device Manufacturer/Model: HP

  • Anytype Version: 0.19.0

  • OS: Android 12, Beta 5

  • Device Manufacturer/Model: Google Pixel 5

  • Anytype Version: v0.3.0-alpha (0.15.43)

Additional context

Just let me know if you should need any further information.

I can’t seem to reproduce it exactly, my objects are getting archived when I try them from the Inbox Tab.

Can you record a video? So I can understand what exactly is happening.

Also, Did you try reinstalling the app on Windows? Does it help?

1 Like

Thanks and yes, I guess it is hard to reproduce. I only experienced this recently with one or two items.

After trying to archive the items just stays there. Here is a little video:

I will also try to re-install.

I uninstalled, deleted the local data directory and re-installed. The item is gone now. Interestingly, without the need to archive it, the item immediately appeared in the Archive section after the sync finished.

Thanks and I hope this helps.

@roncz

Yeah, It’s hard to reproduce…. I don’t know the actual reason behind it, that’s why… I wasn’t able to report this bug a few weeks earlier, as this same thing happened to me. And I re-installed the app, and It worked perfectly after that. :man_shrugging:

1 Like

Is this still the case.
And may this be the same bug as mentioned here?