Issues with Bolding Text

Describe the Bug

When I highlight the text, and hit ctrl+b or the ‘B’ button in the editing toolbar, the text itself doesn’t always bold or return to normal - sometimes it’ll bold the text after it, sometimes it ‘unbolds’ the text preceding it. Quite a strange one!

To Reproduce

Steps to reproduce the behavior:

Honestly unsure - it doesn’t happen on all my text, specifically it happens with this one (not sure about the ones above - I’ll give it a test!). I tried making a new page (with a two column setup, and some text), but it worked perfectly fine? So I’m a bit perplexed as to why this is happening!

But to reproduce:

    1. Highlight text.
    1. Either ctrl+b, or clicking on the ‘B’ in the editing toolbar.

Expected Behavior

Should just bold the selected text!

Desktop:

  • OS: Pop!_OS 20.10
  • Device: PC
  • Version: 0.17.7

I can also test this on Mac and Windows later today to make sure it’s not just the OS or the computer itself!

Edit to Add:

Something else that seems to happen (Just for this one bit of text! It’s actually cursed…) is I’ll open the page sometimes and random bits of the sentence will be bolded. I’ll have left it as:

Interviewing & Advising: 5:15 CST 26th March 2021

But the next time I open it, it looks like this instead:

Interviewing & Advising: 5:15 CST 26th March 2021

@gabrielle Thank you for your notice! It has been added to the bug tracker.

1 Like

Hey @gabrielle :wave: Do you still face this issue with the latest version of Anytype?