Issue about delect unnamed file

What’s The Bug?

When I generate an unnamed object from a template, moving it to the trash results in it not being searchable and deleted.

How To Reproduce It

  1. Creat an unnamed object;
  2. Move to Bin;
  3. Go to Bin;
  4. The page on Bin keeps searching and no response.

The Expected Behavior

Every deleted object should be showed in Bin.

Device

Macbook, Iphone, Windows Labtop

OS

Macos sonoma 14.2.1, IOS 17, Windows 11

Anytype Version

V0.37.3

Technical Information

作業系統版本: darwin arm64 14.2.1
應用程式版本: 0.37.3
構建版本: build on 2023-12-27 14:14:53 +0000 UTC from at #a6b9e08d3091e8a9c17b0b50e3d591612d609bd5(v0.30.4)
庫版本: v0.30.4

Do you mean deleting the Object Type using the right-click context menu, as shown here?
image

If so, you should know that deleting an Object Type Block doesn’t delete this Object Type as the block only represents a link to this Object.
To actually delete your object, you need to open it and delete it from this menu at the top right, as shown here.

I invite you to vote for this feature request as it might represent what you’re looking for, if not, don’t hesitate to submit a feature request yourself:

No, the error happened when the unnamed object was moved to Bin, I guess the duplicate unnamed objects are unable to search which resulted in loading and no response,as shown here.

I can’t reproduce the bug.
Apparently, you have this bug on macOS, but you listed three different OS. So is this bug reproducible on all of them? If not, please edit your first post.

I tried to reproduce what you described, tell me if it’s correct.
Untitled already created template

The bugs happened in all platforms, it is not moving the template to the bin.
It happens when I create an object in the set from the template, then move the unnamed object to the bin.

May be this is not the cause, but all unnamed object can not be founded in the bin for now. Is there any other way to empty the bin?

You didn’t mention the Set in your report. Please add this detail in your first post as well as all the detailed steps needed to reproducing the bug, ideally a video capture, so that we can reproduce it and the developers can fix it.

I’ve tried to reproduce it again with your latest instructions, but I don’t have the same result as you.

1 Like

This report has been added to our issue tracker and received by the Development Team.

Hello @skite

It seems that you are facing the work of our garbage collector.
If you create blank object (no matter how - using plus, from set or from mention in block), open it and close without any change (no name or other relation is set, no blocks are created), than it is deleted completely without moving to the bin.
This mechanism was designed to avoid making big amount of empty objects.

If you move object to bin manually, it will apear in the bin, no matteris it empty or not

1 Like

@skite Could you please verify @kirillston’s conclusion by testing if this behavior persists after adding any content to the object?

@kirillston @Angelo
The conclusion is that I imported a markdown file from another software to cause the problem. The reason should be that the document name is Chinese caused by encoding problems, the document moved to the bin can not be indexed, and other documents also because of this document can not be indexed.

The other objects can not be indexed because this document can not be indexed. If you can not be indexed, you can not select “Delete All”, and the cell phone software can empty the recycle bin without indexing, so the problem is solved. Thanks for your help.

BTW, deleting the object generated by the blank template will not cause the problem, it’s my wrong judgment.

1 Like