IOS always crashing on startup after initial login

Describe the bug
A clear and concise description of what the bug is.
Have been part of ios test since the start, however I have not been able to use it. I am able to login after a fresh install but as soon as I close the app I cannot open it back up. It will crash and I will be suggested to share feedback. After sharing 10 feedbacks or so I am posting here :wink:

To Reproduce
Steps to reproduce the behavior:

  1. Install testflight
  2. install anytype
  3. login use passphrase
  4. let the app sync and the home page load (10minutes)
  5. Close app
  6. Open app
  7. See “app crashed” error mesage

deleting the app and testflight and reinstalling results in the same. Have tried 5 times over the course of several weeks with no luck

Expected behavior
A clear and concise description of what you expected to happen.
Ios application works

System Information:

  • OS: ios 15.1
  • Device iPhone 7 Plus
  • anytype v 0.7.0
    (there are 3 other builds here as well, 0.6.0 and 0.4.0 if relevant)

Additional context
Add any other context about the problem here.
The fact that it loads after login makes me think its not an access issue. I didnt see anyone else post this issue though so not sure how to troubleshoot. thanks!

1 Like

Hey! It’s under investigation and we are looking forward to fix it ASAP.
We will get in touch as soon as possible

hey @Vova i just tried again for the sake of it and its working now! seems like 10th time was the charm. Not sure if you did something in the background but seems to have been resolved thanks!

1 Like

@Coursecharter cool! There shouldn’t be any more crashes during sign-in, cause it’s happening mostly during the first sync. But we still see problems in this (first sign-in) scenario, so we will continue working towards fixing them.