Inline images disappearing

Describe the bug

Inline images disappear from objects. This seems to happen specifically when an object is loaded from disk rather than from memory.

To Reproduce

    1. Add an image inline to an object.
    1. Quit Anytype
    1. Start Anytype
    1. Go to object
    1. Observe that inline image is missing.

Expected behavior

Inline image should be preserved in object saved to disk.

Desktop (please complete the following information):

  • OS: macOS Big Sur
  • Device: MacBook Pro
  • Version: 0.18.59

Other details

Restoring from past versions does not bring images back. This appears to be an issue with how objects with inline images are saved to disk.

1 Like

I’m on Arch Linux and I CAN’T reproduce it. My Inline Image remains as it is 🤷

1 Like

@PeterG Hi! Sorry for the long answer! Can you record a video on how to reproduce this, because I can’t

Hi all, thank you, I will record a video when I get home.

In the meantime, I was able to find a bit more specificity to the bug. It only happens when there is a column layout. If the image is the only block in a row, it saves fine. If there is an image next to a block of text, however, the image disappears on quit and reload.

1 Like

I can repeat neither the first way nor the second way. Await for a record

I could replicate the issue using the instructions from the reply @PeterG. See attached video

Version: 0.18.68

OS: Ubuntu

2021-09-01-17-43-23.mp4

1 Like

Thanks @lorenztiel , you beat me to the video! The behavior I’m seeing is identical to yours. Single images work fine, images in columns disappear.

This may be a mac-specific issue. Please let me know how/if I can help narrow reproducibility conditions further.

@lorenztiel Thank you for the record! @PeterG Thank you for your notice! It has been added to the bug tracker

@lorenztiel @PeterG
Is this still happening in the current version?