Incompatible Version


I see “Incompatible version” in the connection status on MacOS. If I click on it I get a dialog that says “It’s time to update” with an update button, however the update button doesn’t do anything. Quitting and loading again does nothing.


Just open Anytype. I see a “No connection” which I don’t recall seeing before. Internet connectivity is fine.


Update if necessary




  • Device:
    Macbook Air 2020
  • OS:
    Ventura 13.4.1 (c)
  • Anytype Version:
  • Tech Info:
    Device: re.local
    OS version: darwin x64 13.4.1
    App version: 0.33.3
    Build number: build on 2023-07-18 21:58:21 +0000 UTC from at #087b1bff0634dc85980f1fb0cd8fcff4512e960c(v0.27.15)
    Library version: v0.27.15
    Account ID: A8fkUMKBWdYGmKFBRyqpoHdtJek3dq9rzM61AFe5VJC9gNdA
    Analytics ID: 0c84747d-4314-469a-b92b-f5abf7781ce6
    Device ID: AAmFEy53rin3yUimFRujcWZskRXKczJhzDCGzo6qojcFddiN

After a while I got a prompt to update and restart. I agreed to do that, and it hasn’t been done, and now I can’t open objects. Not sure if I should quit and start, or wait. Went away for a few minutes, now I’m “Entering the void…” Application is unresponsive, will have to force kill maybe?

… After doing so, it’s back to the same state.

Hey @gearcat,

Try downloading the most recent version from GitHub. You are using a super old version. v0.33.3 probably uses an incompatible library version. Since it is that old, it likely will not successfully auto-update. That is why you must download the latest stable release - v0.35.0. This should definitely fix your problem.

Hope this helps!
-James @23jjl

That fixed it. Looks like I was just running it out of my Downloads directory the whole time. Maybe that’s why it wasn’t updating properly? I downloaded 0.34.3 off the link on I synced local changes to other devices successfully.

Oh, good! I was going to say, that version is way out of date and uses a really old library version. I led you to the v0.35.0 download because I’m sure that it will show up on the official download site soon (and it’s not pre-release because those are labeled as being alpha or beta). Just wanted to simplify the download process and save you some time and bandwidth :wink:

I wonder if we could replicate this fail to update bug somehow… I think that I just ran the .app out of the download directory and thought nothing more of it. Could that have caused it?

edit: I got an update and restart prompt. I agreed. Again, no update and restart occurs.

Have you tried killing the app or restarting your computer? Sometimes it behaves weirdly, like even mine didn’t update the first time most recently when I updated in the app to 0.35.0. It closed the app, but it didn’t actually go. This has been problematic in the past but I thought they already fixed it once.

I have killed the app. No effect. I haven’t restarted the computer. I’ll try that and let you know how that goes.

Rebooted, still Version: 0.34.3. I don’t see an explicit “check for updates” function. Am I not seeing it somewhere?

In the “Version” menu I have “Release” selected.

Try selecting the “Pre-release” menu and seeing if it will update correctly.

Yes, it updated to 0.35.0 right away

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.