In simple-table, cell vertical range always changes

WHAT IS THE BUG
After updating to 0.37.0:

  1. In simple-table, the header row is always squished.
  2. Cell vertical range always changes and the setting of vertical align doesn’t work, as shown below.
    PixPin_2023-12-25_21-40-31

HOW TO REPRODUCE IT

  1. Open an object with simple-table
  2. Click on some cell (or set the vertical align)
  3. Close the object
  4. Re-open the object

THE EXPECTED BEHAVIOR
The cell vertical range should remain fixed, just as it is in 0.36.0

  • Device:
    Desktop, Xiaomi Book 16, Surface Pro 8
  • OS:
    Windows 11
  • Anytype Version:
    v.0.37.0
  • Technical Information:
    Library version: v0.30.3
    Account ID: A8GnWbFf93jy9cCKmv9x93camzT7zZwwtqVSFq7TJNhMhfqe
    Analytics ID: 560e3ed8-ebb9-4b0c-8f31-a65b2d69f002
    Device ID: 12D3KooWKGLMVShnd98KybK1VxpPsg4n1Ws14gxa4aQFAPN5V5Qu

Do you have line breaks there?

@Razor same behaviour on my end - no text or line breaks needed, just a fresh table

1 Like

In my GIF, there are line breaks indeed.
However the other simple-table, without line breaks, face the same isssue.

Line breaks is a different issue, the video above is a new bug indeed, it comes from editor slight change in cell styles, so I’ve fixed in 0.37.3. Concerning line breaks - last line break is trimmed, no solution yet, this was done on purpose because of how text editing works, so I’ll return to this later.

2 Likes

This topic was automatically closed after 5 days. New replies are no longer allowed.