Images got broken, relation value lost

Describe the bug
Missing information in all existing grids
Columns are no longer populated with field values, only the name of an object is displayed. This is also true for a new grid i just created.

All images in all objects show “image is broken”
image

This is the worst ;-( … i will loose all my screenshots … i know there is always a risk using alpha software and i don’t blame anybody.

To Reproduce
Steps to reproduce the behavior:
Open updated Anytype :wink:

Expected behavior

System Information:
Windows 10, 64bit

Additional context
After installation of update 0.22.1 i’m happy again :wink:

6 Likes

@mkoechli Thanks for reporting! Just wanna say that your files and sets are safe. This is just a bug in the indexing system. Already fixed and should be released within 1.5 hours

4 Likes

Images are broken for me on 0.22.3 as well. Using an older version(0.21.9) seems to load them properly

2 Likes

How can I use an older version?

Solved it by changing the URL on https://download.anytype.io/ :grinning_face_with_smiling_eyes:
https://at9412003.fra1.cdn.digitaloceanspaces.com/Anytype%20Setup%200.21.9.exe

Unfortunately, we can’t reproduce the problem with broken images on any desktop version from 0.22.1 to 0.22.3

@Ryan @lynxlove let me know if you can help to debug this issue on yours side. You can write me on telegram or discord @requilence

2 Likes

DM’d you on telegram

yeah after updating to 0.22.3 I am facing the image link broken issue

2 Likes

Facing the same issue on the android app v0.5.0.The images are loading on v0.4.4 though.

1 Like

Also facing the same issue. Curiously, one installation of Anytype I have on my phone that migrated from 0.4.4 to 0.5.0 loads images properly (after some waiting), but the other installation that had its data cleared on 0.5.0 fails to load images at all.

2 Likes

This still appears to be an issue on macOS intel version 0.23, none of the images are loading.
Also an issue on the linux client.
I tried clearing the cache and still no luck. It does seem to work on my Android device.

1 Like

When I go to older pages(days-weeks ago) and look at the images, it says for all the images in the page that the “image is broken”. Are all my pictures permanently gone? I am on the latest anytype build on a linux system.

1 Like

they are not permanently gone. They are all on your machine but failed to be indexed due to a bug. We have reproduced this issue and fixed this bug. The fix will be available in the upcoming release in the next hours Anytype Desktop 0.23.5

3 Likes

Anytype Desktop 0.23.5 (Windows) fixed it partially for me. Some of the image is broken errors have disappeared, but it’s still showing for older images.

Do you have this on your list already? Thanks in advance.

2 Likes

yes for some of my page the imge link is still broken !

Did you try a clean sync after the update? If not, can you try once?
I had this issue after update in the android app for few images but clean sync solved it for me

what do you mean by clean sync ?

Deleting working directory and logging in again

yeah i have did that two times

Okay this is weird. After updating the app, all my images worked on the linux app. Updated Android app to the latest version and it solved the issue on android as well. However, I just tried a fresh install of anytype on a windows machine and 5 of my images are still broken but all of them are available in the android version. I’m going to reupload them but I want to let you know that there still seems to be an issue :thinking:


Found an easier workaround to get back your images (This only works if your android app has the images available)

  1. Open the desktop app and keep it in foreground (This step might not be necessary)
  2. Open the android app and navigate to the page with the issue
  3. Long press the image having the issue and duplicate it
  4. The image should immediately be available in the desktop app
  5. Delete the original image block to remove the Image is broken block in the desktop app

This still did not restore one of my 5 image blocks having the issue, but I reuploaded it

2 Likes