ICON images show in graph view as separate objects

Describe the bug

icon images show up as objects in graph view => duplicate since it already shows on the initial object preview

To Reproduce

Steps to reproduce the behavior:

    1. Create object
    1. Ad icon image
    1. Go to graph view
    1. It appears as a linked object

Expected behavior

Cover/icon images are excluded from graph view

System Information:

  • OS: W10
  • Device Manufacturer/Model: Desktop
  • Anytype Version: 0.20

Additional context

Other images:

1 Like

I’ve already raise an Issue or a Request to remove the cover image and page cover from the sets view few weeks back. I guess we could merge one into the another as it would be best to remove them from any type of views from any type of media sets since none would expect page covers and images to show up in it?


1 Like

I don’t seem to have the issue you described, in my case the object and it’s cover image are supposed to be related but they are not


@michaellw Yes I faced a similar situation but not a cover image but an imaged placed within a page do not have any link to the page in the graph view. Can you please raise it as a separate issue?

@lynxlove refer to [1095](The images & files of a certain type of object are not linked in Graph view)

1 Like

@michaellw maybe it’s the icon image ? I use the same image for both on all my pages so I’m unsure there

@Inkqb I carefully read the pictures you posted. The link should be the icon image. Currently, only the icon image shows the links, while other images do not show the links.

1 Like

@michaellw You are correct I’ll update the post

Sadly can’t update the title, it should be changed to “ICON images show in graph view as separate objects”

Changed it to the requested title.

On my graph view all icons are shown as wanted, no additional links. Please check the latest version.

Closing the topic because there is no response. Please open a new topic or flag this one to be reopened if you still experience this issue.

This topic was automatically closed after 12 days. New replies are no longer allowed.