"i" displays as "N°" in H1 and H2

See attached image. The issue is only visual – copying the text out of Anytype into another text field, the “i” appears as

normal. Only H1 and H2 blocks are affected.

The issue does not occur on Android.

To reproduce: Create an H1 or H2 block and type the letter “i”.

Desktop: Anytype 0.16.4 on Windows 10.

Additional context: The computer is set to Turkish language.

The issue does not occur when the system language is English.

1 Like

@DenizAksimsek Thank you for the notice! Can you write, Turkish was set as the system language or as the keyboard set? Also, did you copy from Anytype to Anytype, right?

@Kirill_Lem

Thank you for the response!

It was the system language. As for keyboard layout, I tried Turkish-Q and Turkish Alt-Q.

I copied to another app (Firefox URL bar). I also tried copying into Anytype. As long as it’s not inside H1 or H2, it displays fine. (Does H3 use a different font? I can’t tell)

@DenizAksimsek I changed the system language and change the keyboard set in Turkish-Q, but I can’t reproduce it. What windows 10 type do you use? I mean professional, home…etc. Also, do you still use Anytype 16.4, or now you use the last version(16.8) and it still reproduces?

@Kirill_Lem Anytype 0.16.8, Windows 10 Enterprise version 1909. I’ll try reinstalling Anytype and updating Windows.

@DenizAksimsek Did all that, no change.

@DenizAksimsek Have you update to the latest version? Does it reproduce there? I had tried to investigate your case but unfortunately didn’t understand what is the reason. Do you have another computer for the experiment? I mean try to reproduce in another machine with the same windows version and if it doesn’t reproduce in another machine, try to understand the difference between you and another computer.

I haven’t been able to get my hands on a different computer yet but the issue is probably with my device… it apparently happens on the Anytype website as well. There’s something about Lcg that my computer doesn’t like.


I’ll report back.

Update: on the website, setting lang="en" on the <html> element via devtools fixed it.

Update 2: It’s broken with lang="az" too.

@DenizAksimsek If you open Anytype site in your mobile device browser, text in site displays normaly?

@Kirill_Lem Yep.

@DenizAksimsek It’s definitely something with your computer.

To be honest I don’t agree with problem belongs to Deniz’s computer. Because I have similar problem. Also I’m from Turkey too.

I use MacOS and Google Chrome.

I’ve missed this issue, I will check

Could you please check here? Graphik LCG font | free download for WEB

I downloaded it but it didn’t work.

Yeah, I see, thanks. We do not use LCG in the app, but use it on the website.

1 Like