I cannot import my backup after installing new version

WHAT IS THE BUG

I cannot login / import my backup after installing the new Anytype version (v.032.3), after clicking “login”, I enter the recovery phrase then I select the .zip backup file.

HOW TO REPRODUCE IT

  1. press login (desktop, mac)
  2. enter recovery phrase, then “continue”
  3. “import backup”, select .zip backup
  4. See error:
    open profile: file does not exist

THE EXPECTED BEHAVIOR

I want to see my profile & data. :frowning:

SYSTEM INFORMATION

MacBook Air M2
Ventura 13.3.1
Anytype v.032.3

This report has been added to our issue tracker and received by the Development Team.

Just checking - from what version did you do the export? Did you upgrade the alpha to the pre-beta (0.31-2 beta) before doing the export?

I did not. And I dont know what version I used before…

I think that might be the problem. The upgrade had to go like this for migration to work.

  • Update the alpha to 0.31.2-beta. This version is solely to support export/backup in a format that the new beta will be able to import
  • Export from 0.31.2-beta.
  • Update to 0.32.x
    Import your backup

If you exported from the old alpha, the new beta won’t recognise it.

It happened to me, and this was the solution.

I downloaded manually the 0.31.9 version, and exported the backup from there.

Then, I could import the backup in the new version.

Great! Thanks for reporting back. @Vagabond0977 could you give this a try?

Thanks to @junquera . Worked smoothly. Thanks for all the help.

2 Likes

This issue has been fixed by the Development Team and will be implemented in an upcoming release.