How to remove every note?

I had a problem with Anytype: The imported files from Notion were not being shown in Anytype. I’d like to try again to import the files, but I want to make sure that I can remove all the previous imported notes before to avoid duplications. Is there any quick way to do that?


Hi @albertoma,

You can do this by following these steps:

  • Create a set by relation, with the relation being “Object Type.” This should put everything that you have in that workspace in the set.
  • Then you can select all the objects in the set by dragging, shift select, or CTRL+A and use the delete key to move them all to the bin.

This should get rid of all of the objects that you have in Anytype so you can freshly import again!

Good luck,
James (@23jjl)


It seems like it works!! Thanks! I have to do that with each type of object, but it definitely works. Maybe there should be an option to automatically do that in Account settings (that, of course, required confirmation, maybe including password).

1 Like

I was meaning like this:

This is in the new beta app, but the alpha (legacy) app should have the same functionality as far as sets go. That way it includes every object (because every object has the relation “Object Type”).


I did what you did and it did kill all the orphans I had, but my graph is still showing all my stuff and when I Ctrl-S to search, I can still visit the same stuff. Only thing that is missing on every page is ‘page’ (so what the object is supposed to be).

Am I missing something or is this expected behaviour?

1 Like

Hi @plotsklapps,

I had a bit of problems doing this with imported items in the Beta app. It’s either the fact that sets, for some reason, don’t seem to play well with imported items or that because of list order and the fact that the set includes everything, that means the set is included in the set (I know, confusing) and it might have gotten moved to the bin before the other objects did - which means it couldn’t have moved any of the other objects because the set got deleted first (I honestly didn’t think of that, but now I realized). The problem now, is that a lot of the types you have are missing - you may be able to reinstall them, but the best idea if you want to clear everything is to try other queries (for example, it looks like you could create a set by object type of pages). Or, if you haven’t emptied your Bin yet, it might be advisable to restore all of your objects and delete them in numerous different sets of different types (as the other person did above - even though it takes more time, you would be sure to get rid of everything - except for maybe some of your sets, because, again the set that you use to query all of the sets you have might get moved to the bin before the other objects). At last resort, although painstaking, I had to delete all my objects one by one (and theoretically - even then I didn’t get everything as I later found templates of object types that I uninstalled).

Hopefully, one of those works,
James (@23jjl)

(P.S. - at least it looks like your search bar in Anytype on Linux works, Windows users like me aren’t quite so lucky :pensive: - but it will hopefully get fixed soon)


I have been doing some more deleting. I currently just want a fresh start now, because I really want Anytype to be my Notion killer. I succeeded in literally emptying the graph, there’s just BLACK screen, so that’s good. But now I have the above objects in my bin, which look they should not be there (Anytype’s standard objects). But I cannot delete them from bin, nor can I restore them. And it broke the app :frowning: Cannot create new objects anymore.

I’ll just try a fresh reinstall from Slack link now. Oh man, Anytype really needs a ‘start fresh’ button :slight_smile:

EDIT (couple minutes later): Well, what about that. It worked. Apparently it had to sync somewhere or my computer had to think things over a bit more, but what I had in mind worked. Graph empty, bin empty, all standard objects back to where they belong. Fresh, clean slate. Creating new objects like pages now working again as well.


Glad to hear it! Sometimes the app gets stuck and it needs restarted or reloaded, for example, various relations don’t show up until the app gets reloaded and I guess the bin can be a bit buggy in the beta version since I had experienced a problem in which I resynced all my stuff after reinstalling the beta app and everything from the bin mixed with everything else and I couldn’t move it to the bin. I also had a minor thing happen (which I then wasn’t able to reproduce) where I just could not permanently delete an object unless I moved something else to the bin - I’m sure everything will get worked out. As for starting fresh more easily in the future, I’m guessing when they introduce multiple spaces that you will be able to delete the space and everything in it - or when they release the beta app and then you will be able to just delete your old account and create a new one without having an invite code (As for me, for the sake of sanity, I’m unwilling to give up my current account so my seed phrase is still the same as when I started using Anytype :wink:).


So in order to get a fresh start in the new AnyType, we have manually delete everything our selves?

1 Like

In the future, I’m guessing you will be able to delete workspaces and create new ones to start fresh. However, the team won’t be implementing this feature for a while. So, yes, as of currently you have to do it pretty much manually. I was able to query some of my objects into sets and mass delete them and then delete the leftover ones, one-by-one.

There are two ways:

  • Delete manually via set of everything.
  • Just create a new account using your invite code or wait for removal of invite codes in the next release

I got it fixed now. i only deleted those objects whos creation dates where wrong and re-imported the export zip file again and it replaces only those ones i deleted. at this point I feel like i am back up and running.