How to enable offline sync mode?

Hello everyone,

I’m trying to have Sync working in offline mode (i.e over lan) rather than over the internet.

  1. I started by creating a profile on PC 1
  2. I copied anytype folder in Appdata\Roaming to PC 2
  3. Now when I edit anything on any computer, it syncs on the other but won’t sync when internet is disabled

The sync indicator shows only “Backup node” without any devices.

I can’t figure out how to get it to recognize other devices like shown in docs:

This is currently not possible. With the release of a node that you can host yourself you should be able to only sync to that node. Right now, the only way to work offline is to either disconnect your machine from the network or block the network communication using some kind of firewall.

I tried applying firewall rules and I successfully disconnected from the node but the 2 computers seem not to be able to recognize each other over LAN.

Are you sure about this? I feel like I’ve read somewhere that this should be already possible, and my experience with syncing new accounts on the same network tells me that the sync is a lot faster than it is over the internet.

1 Like

For you second step, there’s no need to copy the folder over to the new device. It might even be better not to iirc.

Yeah, it’s mentioned on the docs “Sync” page here that it’s possible:

What kind of rules did you apply? Could it be that you blocked the entire app from using the (local) network?

I went to the IPv4 settings of Ethernet and set a local ip, a gateway and left DNS to blank so that my PC will be discovered on lan but cant connect to the internet.

I have some programs that run on LAN only and it worked fine after I made the modifications above, so, still the problem is with anytype.

Even when both PCs are connected to the internet, both of them sync only via the backup node, they don’t see each other directly.

Just thought of something concerning this…

If you have your PC(s) treating the network that you are connected to like a public network it won’t be able to make contact with other devices on the network. Make sure that your PC is treating the network as a private network. Here is what the settings for this look like on Windows 11:

Also, depending on what network that you are on, some times peer-to-peer connections can be blocked. For example, I know that a lot of colleges block peer-to-peer connections on their networks so it’s a personal sigh of relief that it works without needing to use a peer-to-peer method of syncing items even if it is slower.

1 Like

I set both PCs to “Private” and it didn’t work, also it’s my home network and every app else works fine.

It may be possible that it isn’t fully implemented yet or that there is a problem with the peer-to-peer sync functionality.

1 Like

I guess I will open a bug report for it then.

1 Like