Hot-fix 0.29.1

Hello Community :wave:

You all may have noticed an unexpected prompt for an update to Anytype 0.29.1 today :fire:

This contained a hot-fix for the broken creation of objects from custom type templates function that many of you were experiencing :ambulance:

Your new templates will now work as expected :tada:
…the caveat is that any templates you made during this time that were broken, still won’t work even after the fix and must be made from scratch.

Simplest/quickest way to do this is:

  • open two windows (shift-cmd/ctrl-N), broken template in one window / new blank one in the other
  • copy the content from the broken template into the blank template
  • delete the broken one after (to avoid encountering it in the future)

Thanks everyone who reported/confirmed this bug and we apologize for any frustration it caused! :pray:

Happy Anytyping and stay-tuned tomorrow for an update on our coming release schedule :radio:

10 Likes

Thanks for the fix but I can’t update and I wanted to know if any one had the same issue.

platform: Parrot OS (Linux).

when I click on “check for updates” it doesn’t do anything.

1 Like

Could anything be blocking the network connection? I got the notification that a new version was available right away, and download and install went very smooth.

1 Like

Thank you so much!

1 Like

The network doesn’t block anything.
And I tried on another network and nothing happened when I checked for updates.

Also I tried to reinstall but the .deb package in the download site is still on 0.29.0

The packages on the download site are indeed not yet updated. This is communicated to the Anytype team :slight_smile:

1 Like

Latest version is now up.

1 Like

@AhmedWael216

Linux V.029.1

All platforms available :point_down:
https://download.anytype.io/

2 Likes