Filters not working properly

Describe the bug

So I created a set for all the Food types in the game Valheim in Anytype on my laptop. Food is devided in 3 types, stamina, balanced and health. For this I have a status relation named type where I fill in the correct food type. See screenshot below:

When creating a new view to show only the stamina food I create a filter:

The filtered result is not complete as seen below, Honey and Raspberries are missing from the list! When clearly they are marked as Stamina food in the first screenshot (or All view).

To make this bugg worse, when I open this on my desktop PC the filtered view is completely empty! If I recreate this view on my desktop PC it still stays empty but when I view it on my laptop it is partly filled.

To Reproduce

Steps to reproduce the behavior:

    1. Create view
    1. Add pages
    1. Create new view
    1. Add filter
    1. Check if filter shows all the correct pages

Expected behavior

Expected to see all the food types marked as Stamina and nog a few missing of even a completely empty list and when synced with my desktop PC I expected to not see an empty list.

System Information:

  • OS: Windows 10
  • Anytype Version: 0.19.0

Additional context

7 Likes

same issue. also each time I open the set view a different amount of objects are missing. If I expect 10 items to show, sometimes 2 will show, sometimes 5.

Maybe it has something to do with the “status” relation type. I seem to only have this issue on that type. Object or tag relation seem to be working so far for me

1 Like

Actually, I just checked again and it seems that object relation types are also not working properly with the filtered views.

1 Like

to add one more thing I learned on this. If objects have the value you want to filter already BEFORE you create the view, it does not show. If you go back to the object, change the value to another and then back to the filtered value, it will then show up in the new filtered view. It seems that the view filter looks for objects that have that value assigned to it AFTER the view is created.

I am now doing a workaround to go back and re-assign the relation values to have them show up in my new views.

1 Like

I recently found out that the IS filter does not work. When I select Has Any of the filters work as intended.

2 Likes

Noticed that filters don’t work on notes for me. If I use the filters “Name is not empty” or “Name is empty” it doesn’t get the appropriate notes. If I use “Name is xxx” it doesn’t get the xxx note either. If I use the doesn’t contain filter that doesn’t work either. Also sort by ascending or descending doesn’t work. Has anyone else run into this?

there are bugreports about this (like mine Filters not working properly)

I believe the is filter does not work at this moment. If you use Has any of then it works properly for me.

1 Like

I can confirm this. I have a set of tasks. But when I create a new view and set the filter to “Status is ‘In Progress’” then the view is empty, even though the objects show up in the view of all objects.

Also experiencing this on version 0.25.4 on macOS (M1 version). Can confirm the “has any of” workaround works, but the “is” filter does not capture everything that has that status. E.g. see below

I have 5 books in my reading list with the “unread status”:

But in my view filtered by “Status is unread” I only see one of them:

I just checked this and the “is” filter worked good for me and found all objects with the tag I searched for.
Please check this again with the latest version.

For me it doesn’t work yet (Anytype 0.27.0):

Has any of:

Is:

All that is changed between the two screenshots is the filter from “Has any of” to “Is”

As the other filters are set to “all”. Could you try removing them and see if it’s still the same?

Same for me: when using “Is” or “Has all of” the Set view does not return the correct Objects. Strangely, even with the Status Type Relation set to "Has all of “empty” (so no Status selected), some Objects are returned:

Once I edit something of the Object (name, Status) the Object is no longer visible, triggering some kind of refresh. Unfortunately, this is not the case for all Objects, making this even stranger…

Like so?

Guess it is still not working for me sadly. When I have time I can try to make a new fresh set, with new objects and see if the filter works? Might be a bug with existing sets that experienced this bug before?

Or are you on a higher (test) version of anytype?

He’s on 0.27.0 right now.

Using Is (Equal) for array type values is actually erroneous and I think it should be removed from available conditions. For array values you should use Has all of / Has any of depending on you case.

I’ve just checked and Is condition is not available for status/tag. Could you please explain how do you create this filter?

I’m able to see a “Is” condition for “Tag” and for “Status”.
image

Oh, sorry, I’ve missed it =) Now it’s removed.

3 Likes

Option is removed, therefore the report is not valid anymore.