Fails to create a project sets

Describe the bug

Cannot create a set of objects as shown in the video
set-creation.mp4

To Reproduce

Steps to reproduce the behavior:

    1. Go to Library > Project > Create > New set of objects
    1. See an error

Expected behavior

Create a sets of projects when clicked on them

System Information:

  • OS: e.g. popos 21.04
  • Device Manufacturer/Model: CustomPC
  • Anytype Version: e.g. 0.19.0

Update

Not resolved in Anytype : 0.20

This happened with every type I tried on.

Update

Crashed 0.3.2 on Android

3 Likes

Hmm… Weird, I can’t seem to reproduce it.

Does restarting AnyType help? Or it keeps happening like you mentioned?
set.mp4

1 Like

@Sedulous Restarting did not help. Also, It happens with every sets. This anytype appimage is updated directly from 0.18.58 to 0.19.0 automatically. It really happens as I posted in the video.

Update

I did a fresh download from the website and logged in and synced directly from the server. Experiencing this issue even after all these.

@Kirill_Lem You could take a look into this.

Describe the bug

(Linux 0.19) When I create a Set of the type “Korpora” (a type that I created) I get a window of the Set but I cant see a table then

And after seeing the empty window of the Set: I created an object in the Library-Page of that type, but still can’t see a table in the set. Also turned a draft into that type, but still no table to be seen in/for that set.

And also, two objects in the window of the set in the Library are listed tho:

And I opened the Set from the Android App (0.31, Android 9) and the App crashed when opening that set. But not with other Sets that i already had.

To Reproduce

Steps to reproduce the behavior:

    1. Go to ‘Library’
    1. Click on the Tab ‘Types’
    1. Click on ‘Create a new type’
    1. Type in a name
    1. Click in ‘Create’ and ‘New set of objects’

Expected behavior

I expected to see a table like in the other Sets that I have.

And the “attributes”/“relations” under the Set-Name like here

System Information:

  • OS Computer: Ubuntu 20.04

  • Anytype Version: 0.19.0

  • OS Smartphone: Android 9

  • Device Manufacturer/Model: Ulefone Armor X5

  • Anytype Version: 0.3.1-alpha

2 Likes

@div3xi This is same as the issue I created.

https://community.anytype.io/t/-/2199

You could merge these both. This issue seems to be linux only.

2 Likes

Describe the bug

Unable to create a set of objects of a type.

To Reproduce

    1. I got to the page of an user-created type. I already have several objects of that type. They appear in the type’s page.
    1. I hit “New Set of objects”
    1. It creates a set, but it is not specific to the type I started from and the “Set of” property is locked and uneditable. Adding a new Set property doesn’t help.

It doesn’t have any kind of interface I can use to create a new object. Basically, it doesn’t look anything like the Drafts set. An identical behavior happens for Anytype-provided types.

Expected behavior

To be able to have a set of a specific type, just like the Drafts Set.

System Information:

  • OS: e.g. Ubuntu 20.04
  • Anytype Version: 0.19.0

Additional context

Moreover, opening the mentioned sets on the Android app (0.3.1-alpha) makes the app crash (forced close).

1 Like

Can be merged with: https://community.anytype.io/t/-/2199

1 Like

@lynxlove @div3xi another merger.

Happens the same on the latest version with the built in types (Human Type) as well

1 Like

I have two such sets which are displayed as a normal page instead of a set in the desktop app. One is of Human type and another is of Task type. I have few other task type sets as well. The Human type set opens on the android app even though it does not in the desktop app, however the Task type set crashes the android app for me when opened.The other task type sets opens fine on android as well

1 Like

@Srinath Hi! Very sorry for the long answer, a can’t reproduce this bug in the latest version. Do you still have this problem?

@Kirill_Lem I still have the issue in the latest version of the desktop app (0.20.9). this seems to be common in the linux version of the app

2 Likes

@Kirill_Lem Yeah. It doesn’t seem to create the type in the set. And was shown untitled in previous versions. However in the latest version 0.20.9 it seems to make the name of the set created and on opening it it doesnot show any database table and the type is missing fron the link i.e set- type- me. After closing anytype and without internet reopening it makes the set go untitled. As @lynxlove said it seems to be happening only on linux

Hello,

It’s the first time I try to create a set and I don’t understand how it works I guess :sweat_smile: I’ve created a Type (Weekly Summary) and two objects with this Type. When I try to create a set, there is nothing in this set.

Idk if it’s a bug, or if I’m just dumb :sweat_smile:

[“Unable to create a set (newbie questions)”,“Unable to create a set (newbie question)”]

This is a bug and happens only on Linux AFAIK. Can you please kindly include your system information as well? BTW, [this is the link](Fails to create a project sets ) to the OG Bug Report. Sometimes, open the set after creating from the Android app fixes this for me, but sometimes opening the set from the android app crashes the app itself

1 Like

Oh okay, here is my config :

All in french, sorry :confused:

And I’m using the latest AnyType appimage

Makes sense then, only linux users are affected sadly :frowning: Hope the new sets creation login fixes this in the upcoming updates

@div3xi Kindly merge this report

2 Likes

Same issue here :confused:

(see https://community.anytype.io/d/1153-unable-to-create-a-set-newbie-question/4)

1 Like