Export to new infra not working

WHAT IS THE BUG

The export of the popup for the new infrastructure does not work. A temp_anytype_backup file is created, but no .zip to be found.

HOW TO REPRODUCE IT

  1. Open Anytype (0.31.3-beta)
  2. Open the migration wizard from the bottom-right icon.
  3. Click ‘Get started’
  4. Click ‘Begin export’
  5. ᅟSelect a destination folder.
  6. Export progress bubble bar shows briefly, and no further messages are shown.

THE EXPECTED BEHAVIOR

When performing the export, I would expect the progress bar bubble to take a while (my anytype2 folder weighs about 1.5Gb), and then show a popup when the export completes; instead of disappearing.

SYSTEM INFORMATION

  • OS:
    Windows 10 22H2
  • Anytype Version:
    v.0.31.3-beta

ADDITIONAL CONTEXT

  • Same error described here: Legacy updated version wrong export
  • The temp_anytype_backup vary in size. If it is the first export I do on the installation, after following the steps described here, it almost always lands on 40Mb. In the next exports, the file barely surpasses the 500Kb size.
  • Exports through the Settings menu go the same way, unless the ‘Zip archive’ option is disabled, then the folder works. Protobuf exports also do not complete.
  • I have tried to zip a normal (non-zipped) Markdown export and use it in the pre-beta version, but it shows the same error as here.
  • Digging up in the developer console, the following error appears:
main.js?0.335228018971206:383894 Error ObjectListExport code: 1 description: rename E:\AnyBackup\pre-release2\temp_anytype_backup E:\AnyBackup\pre-release2\Anytype.20230523.142654.82.zip: The process cannot access the file because it is being used by another process.

I assume this is either the antivirus doing funky stuff, or that another Anytype instance is running without my knowledge.

Can you try to do the export again, and make sure you have killed all Anytype processed before (re)starting Anytype?

1 Like

From where should I start? I think I’m uninstalling, and installing again the public version. Maybe I have done something wrong in the process, and I’ll make sure to reboot between installations.

You can quit Anytype, check the taskmanager for left over Anytype processes (and kill those if still present), then run Anytype again. You should be prompted to do the export again, but you can manually initiate it by clicking the ? in the bottom right of the screen, and then the item with the "update to 0.32.0 (which is just a button to start the export, it does not actually update Anytype).

1 Like

I’ve tried this several times. There seems to be nothing in the background other than the Anytype process itself and the helper.

Thank you, I didn’t have time to finish this post at the time. I can’t say why this error appeared, as the first time after installing the updates everything worked, but afterwards I uninstalled and installed versions many times, worked with program folders, deleted and edited some of them. This error occurred after one of the installations (before that all versions of Anytype were closed and uninstalled)
All other installations and deletions after this error occurred did not help, so I had to use an older backup

1 Like

Did you manage to fix the problem? Because I have reinstalled everything from public and so far, no luck :frowning:

Hi again! The problem is now fixed, and for those of you that might have the same problem, these are the steps that I have taken:

  1. Uninstall Anytype, all installations (at the end, I had both the pre-beta and the pre-release both installed).
  2. Reboot.
  3. Install public release.
  4. Reboot.
  5. Switch to pre-release.
  6. Reboot (there might be a pattern here…)
  7. :warning: Start Anytype with administrator privileges-
  8. Start the migration wizard from bottom right interrogation symbol.
  9. :warning: Choose a folder for which you have sufficient permissions to write to. Remember the folder, obviously :slight_smile:
  10. Uninstall Anytype pre-release.
  11. Reboot.
  12. Install Anytype pre-beta.
  13. Reboot.
  14. Import your files.

I want to believe that 4 reboots are not strictly necessary, but I was starting to get nervous, and it worked :smiley:

3 Likes