Error: failed to run server

Describe the bug
Trying to open app and get error pop-up:
error: failed to run server
error: spawn eperm

To Reproduce
Steps to reproduce the behavior:
Happens when opening the app.

Expected behavior
Expect the app to open.

System Information:

  • OS: Windows 11
  • Device Manufacturer/Model: HP Omen
  • Anytype Version: unknown, can’t open

SOLVED: need to adjust permissions in windows 11 firewall to allow for both public and private. there were two instances in the list that needed to be adjusted.

Can you try clearing the working directory(Open anytype → File → Show working directory), uninstal the app, re-download it, install and try logging in again? This issue has been reported before by few others in telegram and the above steps usually have solved the EPerm issue for them

I also had this problem

I’ve tried this uninstall-reload behavior multiple times, but nothing works.

Do you use an antivirus? Can you try whitelisting it or disabling your antivirus to check if this solves it?

Thanks for your reply, I don’t have any antivirus installed except windows security center.

FIXED!

i tried the uninstall and reinstall a few times. would work to open once and then back to broken for every time after that.

thanks to @mKay i looked at virus settings. using the default windows11 settings. changed for antivirus, which didn’t help. what worked was adjusting permissions to the firewall. there were two instances of anytype on the firewall list. one was set for only public and one was set for only private. i changed both to allow for both public and private. everything works now (so far).

3 Likes

@mKay Thank you for help!

1 Like

Thank you for help!!