Diary entry type deleted and can not install. It works on mobile

The bug I am having is that I have lost all my Diary Entries when I use the desktop version. The Type Diary Entry has been removed and when i try to re-install it nothing happens.
I am still able to see all my entries on the mobile version.

I am not certain how to reproduce this. I created the Journal set on desktop using the Diary Entry query. It was working great on desktop and mobile. Then today when I tried to use the set on my desktop there was a message saying to check my type and relation library because a type or relation had been removed and needed to be installed to keep using the set. I went to the library and noticed that the Diary Entry type was not installed anymore and tried to install it. Nothing happens. I tried installing other types and they work.
Can you help?

Is the type in the Recycle Bin?

If it is there, try restoring it before installing it.

I had this same problem when clicking install doesn’t work when the type exists in the Bin. Restoring it solved the problem.

1 Like

Thanks for your reply! I didn’t think of that. I just looked and it isn’t in there. It is weird, because it works on my phone just fine. It wasn’t a type I created. It was in the Anytype library.

It may just be a bug. In the meantime I decided to make my own type and recreate a new journal. It is working for me and maybe it will fix itself in the next update.

Thanks again!


Hey, please fill in the bug report templates properly when filling bug reports (especially the technical details part). Can you please share those now?

I will do that next time. Looks like the update fixed it. Thanks for your interest.

1 Like