Desktop app stuck on "Logging in..."

App appears to have auto-updated to 0.18.5 but now I cannot access anything - app is stuck on the “Logging in…” screen :frowning:

I had that happen to me last week on my windows desktop. I had to do a full shutdown/restart and it started working again. If I remember correctly there was an extra process of Anytype in task manager that had gotten stuck open and was preventing any new sessions.

@jayenicks good shout - unfortunately, that didn’t work - in fact it only shows this now:

Work machine, so likely something they’re blocking, but Anytype really needs to be able to sync across standard ports etc. if it’s to work on corporate machines.

Copied across the anytype2 folder from my personal machine and now I’m back at “Logging in…”

Sadly, this means I can no longer use the app on my work machine at all.

I had the same issue. This fixed it:

    1. Exit anytype
    1. Rename the anytype2 folder to anytype2-old
    1. Start anytype
    1. Sign in and wait for backup sync

thanks @Fred - unfortunately, sync is blocked for some reason (over-zealous corporate machine)

renaming the folder, restarting, or reinstalling, all result in the same spinner; if I copy the folder from a working machine, I get “Logging in…” but it hangs.

@applepies Hello, I’m sorry to hear that you have been blocked out of your Anytype account :frowning: I want to help you, but I need to get some details. Can you DM me at Telegram(https://t.me/requilence) or at roman@anytype.io?

@applepies Do you still have problems with this?

Hey @Flip

Yep, last time I checked. Tbh, I’ve not been able to use anytype at all because of it, so only install it every month or so to check if it’s still broken. I don’t anticipate it’ll ever work though (specifically on my work machine) as the vast majority of ports are blocked unless there’s a business reason to have them opened.

I’m assuming sync still happens over a custom port, rather than 443?

Hey, I’m not aware of any changes regarding the ports. There is a feature request for supporting a proxy here:

If it’s only on your work machine, where you know the ports are blocked I would close this bug report, okay?

Yeah go ahead. Like I said I’m not using it anymore sadly.

Thanks for the reply. Maybe we see you back, once proxies are implemented.