Desktop app keeps crashing

Hello, new here! I sent an email to dev@anytype.io but got no response, so I’m reposting here.

Describe the bug
I can’t seem to open the desktop app. While “logging in”, this pop-up shows up: “Anytype helper crashed. You will be directed to the crash log file. You can send it to Anytype developers: dev@anytype.io.” When I click ok, it opens a window with a new log file, then restarts Anytype showing me the same message again and creating another log file. This happens in a loop so I had to use the Task Manager to close the app.

I emailed the address mentioned above and sent a copy of one of the log files. (File not supported here in the community.)

I tried again the following day and the error message changed to: “A JavaScript error occurred in the main process.”

To Reproduce
No idea how to reproduce behavior, the app was working properly when I installed it the first time. Already tried reinstalling, same results.

Expected behavior

System Information:

  • OS: Windows 10 Home
  • Device Manufacturer/Model: Acer Aspire
  • Anytype Version: 0.26.1

Additional context

Hope someone can help me with this problem soon so I can start using the desktop version. Thank you! :slightly_smiling_face:

1 Like

For using the desktop version again, just go to the work directory as soon as you enter the app and then in the work directory, delete the data folder, and you would be good to go, theres a LOCK file in the data which got corrupted or something as such im not really usre, i faced the same error today, it doesnt matter if you reinstall the app, if you arent clearing up the data you have stored on your device, the apps not gonna ‘restart as bran new’, if you still facing problems, clear the whole work directory and im sure you would be able to log in again, the only problem is you migh lose some image files through sync as its kinda buggy as of now the nodes arent solid! and about the bug of crash, idk the fix but i have got the workaround to make anytype work again

2 Likes

Thank you for this explanation. I already fixed it but wasn’t sure what I did differently to make it work. Unfortunately, I did lose all my data and objects as the syncing isn’t working anymore. :pensive: (Already contacted support about this new issue.)

you didnt lose your data yet, its in the cafe nodes and you are just not able to access it, thats very weird you are not able to access your data, you sure you doing everything right?

Yeah, I am hoping to get it back from their nodes. I already checked my firewall and made sure that the app has permission. Basically, every time I do a reinstall, I lose my objects and only get these ‘empty’ boxes in my Favorites that never syncs.

EDIT
I realized I posted a mobile screenshot, but it’s the same in pc. Older pages/objects/sets don’t show up again.

try to download a previous version

2 Likes

I believe the issue has resolved itself. @Kerstie contacted us saying it was possibly something to do with firewall, if I’m not mistaken?

I’m honestly not sure. The crashing resolved itself after a reinstall. The syncing issues are still there despite firewall permissions and my objects/pages/relations have yet to resurface. But I talked about it on another post topic. Does that consider this bug closed?

I will choose close it for now by marking it resolved, we can always reopen it off the issue returns

1 Like

I am facing the same issue. I never had this issue before. It came out of the blue.

System Information:

OS: Linux
Device: Desktop
Anytype Version: 0.29.12-beta
1 Like

i have also been facing this issue for 3 weeks on desktop linux

1 Like

My desktop app is also crashing whenever I try to open the app. Starting the app will load the home screen with my objects but then it stops and a pop-up says: “Anytype helper crashed.”

OS: Linux
Device: Desktop
Anytype Version: 0.29.1

Attempts at fixing it:

  1. Renamed anytype2 config / data file in “.config”. Logging in successfully creates a new config / data file but the same crash occurs. However, the crash occurs before any objects are loaded.
  2. Renamed anytype2 config / data file in “.config” and reinstalled anytype. Fails the same way as attempt 1.

Note: Still have working access on my android phone (0.12.0-alpha, Library: 0.23.3)

Same crash log each time:
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x28 pc=0x1c387c1]

goroutine 13151 [running]:
github.com/anytypeio/go-anytype-middleware/core/block/editor/table.normalizeRow(0xc0100af440, {0x0, 0x0})
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/editor/table/block.go:185 +0x41
github.com/anytypeio/go-anytype-middleware/core/block/editor/table.(*block).Normalize(0xc014603370, 0x2ab4080)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/editor/table/block.go:58 +0x2d8
github.com/anytypeio/go-anytype-middleware/core/block/editor/state.(*State).normalize(0xc0100af440, 0x0)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/editor/state/normalize.go:45 +0x188
github.com/anytypeio/go-anytype-middleware/core/block/editor/state.(*State).Normalize(0xc0100af440, 0x18)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/editor/state/normalize.go:25 +0x34
github.com/anytypeio/go-anytype-middleware/core/block/source.(*source).buildState(0xc00d7c5450)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/source/source.go:327 +0x30e
github.com/anytypeio/go-anytype-middleware/core/block/source.(*source).readDoc(0xc00d7c5450, {0x2aa7a50, 0xc00e977180}, {0x2aa7e08, 0xc017df88c0}, 0x0)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/source/source.go:289 +0x9c5
github.com/anytypeio/go-anytype-middleware/core/block/source.(*source).ReadDoc(0x203005, {0x2aa7a50, 0xc00e977180},
{0x2aa7e08, 0xc017df88c0}, 0x8)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/source/source.go:170 +0x2d
github.com/anytypeio/go-anytype-middleware/core/block/editor/smartblock.(*smartBlock).Init(0xc017df88c0, 0xc01602ea20)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/editor/smartblock/smartblock.go:222 +0x7f
github.com/anytypeio/go-anytype-middleware/core/block/editor.(*Page).Init(0xc01602f3b0, 0xc01602ea20)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/editor/page.go:58 +0xf9
github.com/anytypeio/go-anytype-middleware/core/block.(*service).newSmartBlock(0xc00066a6c0, {0xc00265e780, 0x203003}, 0xc01602ea20)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/service.go:1185 +0xd82
github.com/anytypeio/go-anytype-middleware/core/block.(*service).loadSmartblock(0x100000000406238, {0x2aa7a50, 0xc00e977180}, {0xc00265e780, 0x39})
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/service.go:1596 +0x8d
github.com/anytypeio/go-anytype-middleware/util/ocache.(*oCache).load(0xc00032c6e0, {0x2aa7a50, 0xc00e977180}, {0xc00265e780, 0x39}, 0xc00fa06a20)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/util/ocache/ocache.go:177 +0x93
github.com/anytypeio/go-anytype-middleware/util/ocache.(*oCache).Get(0xc00032c6e0, {0x2aa7af8, 0xc00ff1ea20}, {0xc00265e780, 0xc002a19dd8})
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/util/ocache/ocache.go:158 +0x39a
github.com/anytypeio/go-anytype-middleware/core/block.(*service).getSmartblock(0xc002a19e18, {0x2aa7af8, 0xc00ff1ea20}, {0xc00265e780, 0x2027b00})
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/service.go:1605 +0x38
github.com/anytypeio/go-anytype-middleware/core/block.(*service).pickBlock(0xc00066a6c0, {0x2aa7af8, 0xc00ff1ea20}, {0xc00265e780, 0x39})
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/service.go:1117 +0x3b
github.com/anytypeio/go-anytype-middleware/core/block.(*service).Do(0x32, {0xc00265e780, 0x39}, 0x277af38)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/service.go:1378 +0xa5
github.com/anytypeio/go-anytype-middleware/core/block.(*service).Wakeup(0xc0131e0f00, {0xc00265e780, 0x32})
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/editor.go:723 +0x25
github.com/anytypeio/go-anytype-middleware/core/block/doc.(*listener).wakeupLoop(0xc00032c370)
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/doc/service.go:109 +0x222
created by github.com/anytypeio/go-anytype-middleware/core/block/doc.(*listener).Run
/Users/runner/work/go-anytype-middleware/go-anytype-middleware/core/block/doc/service.go:66 +0x5b

1 Like

Are any of you still suffering from this bug? It should be resolved in the next release but we can offer you guys our Beta version if you cannot wait.

1 Like

I’m still having the same issue - is there a more recent version than 0.29.1 publicly available? I’m happy to try the beta version if it means I can access my notes through desktop again - Thank you so much!

Did you try to move the Anytype2 folder (C:\Users.…\AppData\Local\Programs\anytype2 on Windows) to force the app to redownload the data from the backup node?

1 Like

Thank you for the reply!

I’m on Linux but I tried what I believe is the equivalent. I renamed the anytype2 folder in “.config” and reloaded the app. Sure enough, after logging in anytype creates a new anytype2 folder including the data and cache file. Anytype crashes shortly after though before completely retrieving data from the backup node (or so I assume).

I’ve also tried renaming the anytype2 folder, completely uninstalling / purging Anytype, reinstalling anytype, and then logging in - the same crash occurs.

1 Like

Please check this with the 0.30.0 release.

Thank you! With the 0.30.0 release, Anytype launches correctly and after syncing with the backup node, I am able to access all my notes on desktop.

1 Like