Deletion of Objects created before 0.21.0 doesn't sync to other devices

Describe the bug
I have objects that where created many many versions before version 0.21.0 via Notion import. If I delete them permanently on one device the deletion doesn’t sync to other devices. Tough deletion for objects as of version 0.18.x (or something in that range; can’t determine exactly) does work and sync as expected.

System Information:

  • Manjaro Linux, Anytype 0.21.1 (old objects deleted here)
  • Windows 10, Anytype 0.21.1 (doesn’t get synced here)
  • Android, Anytype 0.4.0 (doesn’t get synced here)

Additional context
Apparently someone else had the same problem. Deleting app data and logging back in after that seems to have worked but I don’t want to try that yet to see if it can be fixed.

2 Likes

So inside the data folder I deleted everything except for account.key and device.key. My public page with name and profile icon got restores, but also all my deleted notes from the bin are getting restored.

1 Like

So are you saying that the notes you deleted from within the bin got restored after your reset?

So it’s been 30 min since the reset. Only 120 notes got restored, I deleted them again.

But in the graph view all the notes are visible and I can open them and edit them.
I opened note from the graph view, sent the note to the bin from within its 3 dot menu, went to the bin and deleted that note but it still shows in the graph.

1 Like

Same thing here between desktop and android. I only had the previous version for each though.

I’m having the same issue.

@ichimga Hi! Are you still have this problem in 21.1 version?

Marking it as solved since there was no reply for @Kirill_Lem message
@ichimga / @Inkqb Do update the thread if you face the same issue again with the latest versions of the app