Delay to start a new block after hitting "enter"

Whenever i’m taking quick notes, or typing a list really fast and i hit “enter” to jump to a new paragraph/note/item and i keep typing, instead of writing my text on a new line, it writes it to the beginning of the first line for a few seconds before jumping to the new one

To Reproduce

Steps to reproduce the behavior:

    1. Create a new page
    1. Write something on a text block
    1. Hit enter
    1. Immediatly start typing anything

Expected behavior

Instead of writing the text to a new block it will write on the beginning of the current one for a few seconds

Desktop (please complete the following information):

  • OS: Linux (Manjaro)
  • Device: Desktop PC (Ryzen 5 3500x, 16gb Ram, GTX 1060)
  • Version: 0.18.1

Additional context

Video footage of the bug
2021-06-02-12-09-34.qt
https://drive.google.com/file/d/1sywfO2-0grXXMLoS4O1wSzApACmxi1Hc/view?usp=sharing

6 Likes

Ive noticed the same, sometimes a bigger delay (on windows in my case)

1 Like

@vincer I just installed windows on the same hardware, weirdly enough the performance is way better, almost no delays (at least not on plain text blocks)

We’ve faced such problem on the low-performance devices before.

That’s really strange behaviour.

Did you have enough free resources in that moment?

1 Like

@Vova Im on manjaro too, here a screen rec. It doesnt happen every time, BUT it seems like anytype executes CR+LF, step by step. and if you hit a key between them, its possible to appear between them.

CR -> Carriage return, back to line beginning

LF -> Line feed, next line

On linux, you should only use LF, maybe this could be the problem.

Rescources should not be a problem as you can see in the htop record besides it.

bildschirmvideo-von-22062021-140042.webm
(What I did: Hit on enter and then a, done multiple times)

1 Like

@Vova Yup, looks like there is something going on with appimage launcher, when i launch the software via the integrated icon on my system by appimage launcher the performance is kinda sluggish. When i execute the .appimage directly the slowdowns arent as noticeable

Face the same issue in the desktop app often and today the delay was around 5 sec for enter and similar delay for the immediate backspace key press as well. The backspace key works fine elsewhere.It is delayed only after an delayed enter key press. Also as reported in this issue, enter key moves the cursor to the beginning of the line first, and then jumps to the next line. Also this delay does not happen often and only occasionally for me

Edit: Added Screengrab
slowness-on-return-key-press.mp4

Has there been a fix to this? I also experience this issue when using app image launcher. Don’t think it is entirely hardware related since the rest of the application for me is fast, like typing down text is super responsive as well as dragging around blocks. Only this seems sluggish.

Issue is still reproducing in 0.21.1


You can check the time at which I press enter and the time it gets handled by Anytype in the video.

Bad performance on Linux is certainly not related to the hardware. I face this issue in Linux as well and I tried Anytype on a Windows VM with Gnome boxes today and the enter keys are instantly handled when the App is used in the Windows VM

Will be fixed in the next release

1 Like

@lynxlove Could you give us some information on your current experiences about this topic?

I’m now using Anytype exclusively on windows which does not exhibit the same behavior as reported before. However, I’ll install linux over the weekend and will report back


Edit:
I tried Anytype on linux today and sadly, the performance is not as good as it is on windows. The linux app is fast in demo mode(during installation), but after installation, the performance degrades by a lot :frowning_face:

1 Like

Please check my post here, if this helps someone: