Date Object Type missing in beta 0.32.* and missing @Today, @YYYY-MM-DD

WHAT IS THE BUG

  1. After migration/import from Protobuf/Markdown zip exported using Alpha versions 0.31.*, the Date Objects that used to be available like this:
    image
    are all not recognized and show up as:
    image

This is a significant bug as it results in Data loss! All the date information is lost. Bug exists in the Windows, Linux and the Android App.

  1. Using @Today would show today’s Date in the YYYY-MM-DD format popup that can be inserted inline. This is not available in the Beta App version as of 0.32.3

  2. Using @YYYY-MM-DD for example: @2023-06-19 would insert that date inline in the Alpha App version. This is not available in the Beta App as of version 0.32.3.

Additional Observations:
  1. There used to be a Date Object Type in the Anytype Library in the Alpha versions. The Beta App doesn’t have this. Instead, I noticed a Date Relation type.
  2. The export did contain ot-date.pb which I assume refers to the Object Type Date protobuf. It is likely that there is some bug with the importer in the Beta App.
  3. Tried creating a new custom Object Type called “Date” to replicate the Date Object Type present in the Alpha App library but it wasn’t useful. I am not sure how the @Today action works or is implemented.
  4. Tried exporting the Date Object Type alone from the Alpha App and importing in the Beta App. It didn’t get added as an Object Type.

HOW TO REPRODUCE IT

  1. Try adding today’s Date using: @Today
  2. Try adding a date using: @2023-06-19
  3. Try importing an Object or full import which has a Date object.

THE EXPECTED BEHAVIOR

  1. Today’s Date should appear in the pop-up menu that can be inserted inline
  2. That particular date should appear in the pop-up menu that can be inserted inline
  3. The correct Date should appear instead of Untitled ghost object!

SYSTEM INFORMATION

  • *OS:
    Tested on: Windows, Linux, Android
  • Anytype Version:
    v.0.31.9 (Alpha)
    v0.32.3 (Beta)

This report has been added to our issue tracker and received by the Development Team.

1 Like

Same there on Mac 12.6.3 with beta 0.32.3

This issue has been fixed by the Development Team and will be implemented in an upcoming release.

4 Likes

@Angelo when is the next release slated for?

19/7 as of now.

1 Like