Custom templates for build-in types disappeared after update

WHAT IS THE BUG

After updating from 0.29.1 to 0.30.0 all custom templates for build-in types (like Task, Company, Article) disappeared.

HOW TO REPRODUCE IT

  1. Create a custom template for build-in type in the version 0.29.1.
  2. Update to 0.30.0.
  3. Open type for which the template was created.
  4. Custom template is not present.

THE EXPECTED BEHAVIOR

Custom template is in place.

SYSTEM INFORMATION

  • OS:
    Windows 11
  • Anytype Version:
    0.30.0

ADDITIONAL CONTEXT

It seems that the sync is completed, only the templates are missing.

Could you try to wait a bit more, or log out and log back in? Finally, you could move the Anytype2 folder (the work directory) to resync your content from the backup node.

I had the same issue and it indeed seemed not all Objects where fully synced/migrated

1 Like

The sync is definitely completed, I tried what you suggested as well as the full reinstall. I know the number of objects and checked that all of them are synced.

I found the missing types in the “Template” type, but still can’t see them in types.

I think what’s happening here is my custom templates are still linked to the same Types as before, but now these types are in the Marketplace. If I understand correctly, when you install a type from Marketplace, a copy of this type is created. These custom templates should be linked to the newly created copy, not the original type that is in the Marketplace. I guess this step was missed during the migration.

Here’s the links:

  • On the right is the original type from the marketplace. I can tell it because I can see the disabled “Install” button when I open it.
  • Both default template and my custom template have links to this type.
  • The Company type on the left is the copy of the marketplace type.

Here’s what I see if I click to the Company type from my library:

  • Only default template is linked to this type.

It’s the same for all types with missing templates.

I can’t change the links manually, I think the templates → types links are hidden. I think the only way to fix this from my side is to create new templates, copy content from the old templates and delete them.

1 Like

This report has been added to our issue tracker and received by the Development Team.

1 Like