Cursor jumping back while typing, still a problem

I searched the forum for this issue and did find many similar posts (the most notable two I’ve linked below). However, all of these posts indicate that a fix has been implement, but the bug still persists.

WHAT IS THE BUG

As the other two posts indicate, while typing the cursor will get stuck behind previously typed characters (see video below). Personally, I have encountered this mostly in titles and only on the desktop version.

HOW TO REPRODUCE IT

  1. Start typing in a page title
  2. See if your title actually appears as intended
  3. In the attached video you will see that all 3 tests resulted in the issue (I made no typos during these tests).

THE EXPECTED BEHAVIOR

All characters typed should appear in the order they have been typed.

ADDITIONAL CONTEXT

As previously mentioned, this issue has been raised before, but both posts indicate a fix has been implemented.

Cursor occasionally jumps back when typing - Bug Reports / Bug Cemetary - Anytype Community

Weird cursor behaviour, characters getting replaced - Bug Reports / Bug Cemetary - Anytype Community

SYSTEM INFORMATION

OS version: win32 x64 10.0.22621
App version: 0.34.3
Build number: build on 2023-08-16 11:07:20 +0000 UTC from at #2815587c8afa3f81e75336226cacecb7fe105e9c(v0.27.21)
Library version: v0.27.21
Account ID: A9kFZ74y6nuzmjSuwKeqZUKrrdsu5xcFkXAsufbLAKrBosXK
Analytics ID: a5852b8f-093c-42c7-96c7-5603e5a1e55e
Device ID: 12D3KooWR3w4eQPpLkCB1ukejKrNs8EskcNtZe7RFVvLQ2UWfJ8u

This report has been added to our issue tracker and received by the Development Team.

4 Likes

Hi,

I encounter the same issue. I was so hype for the Anytype release but I notice that when typing quickly on the Desktop, some characters get deleted. Looks like the sync is interfering with the typing to me, so maybe just delay the sync offset, so that it does not permanently sync but after a couple of seconds maybe. But I do not know your code.

It’s very obvious on the Windows Desktop app.

Device: Bumbee-Laptop
OS version: win32 x64 10.0.19045
App version: 0.34.3
Build number: build on 2023-08-16 11:07:20 +0000 UTC from at #2815587c8afa3f81e75336226cacecb7fe105e9c(v0.27.21)
Library version: v0.27.21
Account ID: AAnqMV7BnEdpvWqXHPuRH4NM6iQagEzyazrzGJqRSQ3msB8G
Analytics ID: 2cc64b3d-1381-4a31-9de6-2e7dd28859e3
Device ID: 12D3KooWHi7FAFg8EYkYD9iuPt4UdHQPUiHPy3sQq58j4oJBV8V3

2 Likes

This behaves like a solved issue.

WHAT IS THE BUG

I’m new to Anytype and started with 0.33.0, but since I have joined Anytype, I have an issue with text randomly jumbling up. After making a few screen recordings, I have noticed the cursor moves backwards while I type, resulting in letters/digits being placed in the wrong place (see video example).

HOW TO REPRODUCE IT

This error appears on the Mac and Windows desktop version of Anytype. I find it can be reproduced more frequently on Windows than the Mac version.

When typing, the cursor will jump backwards while I am typing. I’ve noticed it is more likely to occur when typing fast. I get a higher success rate of producing what I want if I type slower.

I have witnessed it happen in a page, note, blog (custom type), description within my blog set.

THE EXPECTED BEHAVIOR

I expect what I type to appear as I typed it.

ADDITIONAL CONTEXT

n/a

SYSTEM INFORMATION

  • Device:
    Apple MacBook Air M1 (2020)
  • OS:
    Ventura 13.5.1
  • Anytype Version:
    v.0.34.3
  • Tech Info:
    Device: MinimlrBook.local
    OS version: darwin arm64 13.5.1
    App version: 0.34.3
    Build number: build on 2023-08-16 11:07:20 +0000 UTC from at #2815587c8afa3f81e75336226cacecb7fe105e9c(v0.27.21)
    Library version: v0.27.21
    Account ID: A6dAfPpn3WSEZWN3gj6xTdtxjf7MNP7crYbzQc66Hm2bJTWG
    Analytics ID: 58ac5718-0948-48b6-a463-e2752d40758c
    Device ID: 12D3KooWCobCgteNpPdaP9xiJUx1eRCq6F4qQdSZ4XQMFMsbhV3D

2 Likes

Thank you codemac, I noted the same issue. Upvoted

Update: I just noticed there is another thread with this bug Cursor jumping back while typing, still a problem

4 Likes

Glad it isn’t just me. Thanks for pointing out the other thread. My search capabilities are clearly not good enough.

I hope this gets resolved soon.

2 Likes

Same issue here indeed with the Windows version, also in the just installed 0.34 update the issue is still there. Even when typing slow i can see the bug occuring. Good luck finding it! :slight_smile:

1 Like

The caret frequently jumps backward while I am typing. I really haven’t noticed any pattern to when it happens, but unlike other bug reports about caret position changes, this one does not require the use of slashes or checkboxes. Just typing plain text in the editor is enough to cause it to happen.

Device Info:
M1 Mac Mini
Ventura 13.4.1
Anytype 0.34.0

Technical Info:
OS version: darwin arm64 13.4.1
App version: 0.34.0
Build number: build on 2023-08-14 19:35:21 +0000 UTC from at #94eb63a1cee9f8f33281a0fa63a28c822f371f44(v0.27.20)
Library version: v0.27.20
Account ID: A9z9d2yi71CU4uiDBdp2CySe6Jv3do9k8gZNDdJucUa1TM9c
Analytics ID: AA9MuN7QpBYNT2DXKzmfa4kqVZNaGLw2dtKA9Y1s7tzVfukD
Device ID: 12D3KooWStY2vUqt2w3V8CheYpLA8fwpnz8oHKfKWHyJrTKjVttY

1 Like

That’s so annoying and happens on Windows version of AnyType (0.34.3) too

2 Likes

Related:

I’m also having the same problem but mainly with the main text portion (not titles). Sometimes it will remove a space between words - I see the space appear on the screen and then it will disappear once more and the words will join together. Other times the cursor will go back to an earlier letter in the word (as someone previously said you type d-o-g and end up with dgo). It’s not consistent when it happens but I can type several hundred words and have at least 10 such occurrences. Also, this happens both on my desktop and laptop.

OS - Mac Ventura 13.5.1
M1 Mac mini and M1 Macbook Air
AnyType: 0.34.3

This should be fixed in the next release. The supposed fix is already in the main branch so if you want to test it, you can build the latest from source :slight_smile:

8 Likes

I’m glad to hear this!

I was about to post that I also experience similar issues. I find it occurs more times when I make titles, but maybe the frequency difference is due to me setting up many templates and redoing many titles and less writing texts.

Thank you for your hard work.

OS: Windows 10 Home
AnyType: 0.34.3

This issue has been fixed by the Development Team and will be implemented in an upcoming release.

9 Likes

Same here on macOS 13.5 in MB Air 2021 and Anytype 0.34.3

1 Like

That would be great.

2 Likes

Amazing. Thank you!!! :smiling_face:

This seems to be fixed in 0.34.4-alpha (only released on GitHub I think)

@stujo7 @Liam8lu @CodeMacLife @micha @Joe1 (and others): could you please test again with 0.34.4-alpha?

1 Like

The problem seems fixed in 0.34.4-alpha. Thanks you!

7 Likes