Copy not working

When typing and directly selecting that word, the popup appears but you can’t use the ‘copy’ shortcut (CMD + C). (MacOS, 0.17.8 )

3 Likes

@Wouter Hi! I can’t reproduce this. What MacOS is in your MacBook?

v11.2.3

@Wouter I still can’t reproduce it

My scenario:

    1. Write a phrase
    1. Select the text
    1. Waiting for popup
    1. Press cmd + c
    1. Set the carriage in the next line
    1. Press cmd + v

Is it the right way to reproduce?

Hi. It’s not working here when you just write a word (or phrase) and directly do cmd + a, cmd + c, go to a new line and try to paste it by cmd + v

@Wouter Can I ask you to record how to reproduce it? I try to reproduce it with shortcuts and without, but the copy works perfectly.

anytype-copy.qt

Sure. I’ve attached the quick time recording.

So the steps are:

  • Typ a word or sentence
  • Select all (cmd - a) | you can see this in the highlight of the ‘Edit’ menu
  • Select copy (cmd - c) -> this is not working and the highlight in the ‘Edit’ menu is not showing
  • As a consequence, paste (cmd - v) is not working

Hope this helps…

1 Like

@Wouter It reproduces! Thank you for your hints, it has been added to the bug tracker.

1 Like

@Vova

I don’t know why you mark it as solved, because 5 month later, it remain unsolved for me. Don’t you consider this a huge bug? I cannot fully try Anytype neither collect bugs and record it because it is too frustrating.

The randomness of the bug makes it all the more difficult to identify, but how can you not have been confronted with it so often?

  • External softwares texts to Anytype works well. :white_check_mark:
  • But within Anytype itself, I randomly cannot copy/paste anything. :x:
  • Same thing from Anytype to external softwares. :x:

Windows 10

Anytype v0.18.68

@AyneHancer I did not mark it as solved, @Vova did. Only he can speak to why. Possibly because there are other issues that track similar or the same problems, e.g. https://community.anytype.io/t/-/1356 Hopefully he can clarify.

@Oshyan

My bad. Indeed but this bug report is only for Android.

1 Like

There are several cases, first one in thread was solved.

We will check new cases and going to work on this one first

2 Likes

@Vova

Thank you :pray:t2:

Unfortunately, I cannot find any pattern to identify the cause.

In the Desktop version (Windows), when I try (Ctrl+C) to copy multiple blocks of text that are nested, the copy doesn’t work. When this happens, the copy of individual blocks stops working as well and even the copy of a section of text wont work. All this happens inside nested blocks. If I close and then open the object, then I am able to copy individual blocks that are nested. But I am never able to copy multiple nested blocks.

1 Like

I can reproduce this with Anytype 0.19.0 on Windows 10. If I select parts of a text within a block I can copy it but if I select a block or a nested block I cannot copy it, neither by Ctrl+C nor by Edit -> Copy.

“Select all” menu or Ctrl+A and copy does not work either.

The interesting thing is that this only seems to happen when I have nested blocks somewhere in the document (as stated by @thiago_nascimentodf). If the blocks are all on one level, i.e. not nested, it works fine.

1 Like

I’m not really sure whether my case shall be listed as a bug report or rather a feature request, since I’m not really sure clients on different OSes have the same features after all. As this is an active thread discussing copy/paste problems, I would like to address my question here.

I’m currently using Anytype 0.20.9 on macOS 11.6/MacBookPro17,1. The copy/paste function (done by using cmd+c/cmd+p shortcut) works properly when I directly paste something into a block. Yet I cannot copy and paste any single block (also, multiple blocks, no matter they’re nested or not); when I select block(s) and tap cmd+c for copying, the selection just disappear and the following cmd+p for paste just fail to function.

Hello, with version 0.21.9 (update of 23rd November 2021) this seems to work just fine. I can copy nested blocks.
Thanks a lot.

Just a note I am experiencing something similar on macOS Monterey 12.3.1 (21E258) with Anytype version 0.25.4. I cannot copy paste text within a block. Very annoying.