‘client.clientspace’: unable to connect (FIXED)

Windows client does not sync with Anytype account. What appears to have happened is that the windows version, through some specific circumstances, no longer downloads properly from the cloud or p2p. This initially prevented me from transferring data between devices, but now prevents me from logging in at all with my recovery code on the desktop.


  1. Synced a PDF file through the file upload on mobile in a regular page.
  2. The files appeared on the desktop client, but could not be previewed. Once downloaded, they simply created a text file instead of a PDF.
  3. Tried deleting the files on mobile but they did not delete on the desktop version. It was somewhere around here that the desktop version stopped syncing (I think). Instead of the usual “synced” dialogue, or “syncing” it permanently displayed “not connected”.
  4. I proceeded to try various things, such as logging in and out, uninstalling and reinstalling the client. All with the same result: “Not Connected”.
  5. Eventually, I uninstalled all the folders for Anytype and tried reinstalling from scratch. Then I started not being able to use my recovery phrase on the desktop version. That’s where I’m at now and that’s what I’m hoping to fix. I don’t know if the initial issue and this one are related, but I can’t help but feel that they probably are.

It’s worth mentioning that throughout all of this the mobile version has worked without issue displaying the “synced” status all the time and being able to use the recovery phrase to get back into the account.


Windows and mobile version both sync and share data between one another.

Error from Netcheck tool (with ip addresses removed):

Here’s the error in the Anytype Windows client:

Razer Blade Stealth 13 2017
Windows 11 22621
Anytype Version 0.34.3

Tech Info:
NO VPN’s or Proxies; NOT on a public or University network. Worked on the same network under same conditions until a few days ago.

This report has been added to our issue tracker and received by the Development Team.

Seems it is some kind of a corporate network tries to subsitute certificate.

1 Like

While we wait for a response from devs about Netcheck Tool results, you can try these trouble-shooting steps.

  1. Check if you’re using a proxy, VPN, firewall, or a company network to connect. If yes, try connecting without these to see if it makes a difference.
  2. Attempt the connection outside of corporate networks or similar setups.
  3. Use your mobile device as a Wi-Fi hotspot for your desktop and try connecting through that.
  4. Try to Log in from another device (& network)
  5. For iOS users, check if the sync status turns green. If not, attempt connecting from different networks.
  6. Ensure that the time on your computer is correct. If the local time is more than 2 hours off, a connection might not be possible.

I have tried everything listed here. The netcheck tool results are already contained in the post.

The only thing that I have not and cannot try is using a different computer as I don’t have access to one. Is there anything else that I could possibly do? This seems like a bug that might be worth exploring, seeing as it has been able to essentially brick the client.

1 Like

Not really sure. I’m just using my home network and it started from there.

You’re absolutely right, this error specifically was the reason we created the Netcheck Tool. Which oddly appears to be exclusive to Windows users…

Cheers, I really believe in this project and I’ll be patiently waiting for the next update. I guess I’ll just have to stick to the phone for now haha. Let me know if I can provide any more data in the meantime.

Would you share the ips please? This is our servers ips, you are not supposed to conceal it :slightly_smiling_face:.
Have you used any proxy or vpn servers?

Oh yeah, for sure. I am not using any VPNs or Proxies. I didn’t even think to check who’s IP it was, sorry, my kneejerk reflex to posting CMD screenshots online. Here’s the full screenshot.

1 Like

I’m just recalling now as well, I think I tried offloading the files to the Anytype node at some point. Also little update, the error is now gone, we’ve upgraded to a plain old black screen.

As a possible bandage, is there any way I can migrate the data from my properly working Android client to the windows client? Any ideas are helpful, just want to get back to using the software.

1 Like

Thanks, I’ve updated the issue.

If you’re seeing all your content with a green status of “Synced” on your Android device, but not on your desktop device: some people have bypassed this by making a hard-wire connection between their devices with a USB cable, to establish a micro-local network. Then waiting for it to sync.

If that doesn’t work, then you can try this:

  1. Install Anytype on a different Windows device (and ideally different network)
  2. Wait for it to sync and then export your Space (include files) as a Protobuf
  3. Copy the protobuf over to your original device and import it into your account

You might end up with some duplicate Objects, so if that’s difficult to manage, a further option is to make a completely new account and import your Protobuf file there. If all goes well, delete your old account and use the new one on both your computer and mobile devices from now on.

1 Like

I don’t have access to another windows device, but I did try it on a different user, at least now I only get the classic ‘client.clientspace’: unable to connect. I tried it over USB network, same result. Could I try offloading the files from my phone to the server? Is that going to run me the risk of completely losing all my files?

Can you guys do anything on your end? Could you rollback the cloud save for the desktop client by a few hours? I probably shouldn’t have tried using this as my daily driver quite yet, but damn, I’m kind of hooped right now. I wish I would have regularly exported to a hard file type just in case. Everyone should do this I think.

I don’t know what to do. I’ve tried on a different network, I’ve tried switching accounts, uninstalling and reinstalling, every suggestion except one because I don’t have access to another computer. Maybe I could try going to the library?

1 Like

Hey there,

Just wanted to add that I was experiencing this every time I put my seed phrase in. I forget how I resolved it - I think I switched back and forth between the Release and Pre-release versions at the top and quit the app. I forget how exactly I resolved it, but I just know that I was trying to log in and experienced the same problem. You could also try reinstalling the app if necessary. Just trying to help and I so wish I remembered what I did to get mine working again. I might have also reloaded the app using CTRL+R.

Just trying to help and hope that something out of this does!
-James @23jjl


@A1ex Can you please toggle between versions as @23jjl suggested?

Also, are you able to access your Tech Info found under the top Help menu?

Would you add it to the Topic please? (you can also DM it to me)

Hey thank you for the suggestion, I gave this a shot a few times but still no luck.

Just wondering, did you check and make sure that your time is set and synced correctly? I just remembered why I was having the problem which was because my time was getting out of sync after booting into Ubuntu and then booting back into Windows. Making sure the timezone was set to automatic and syncing the time fixed the issue.


Alright, no way, it actually worked. I was losing it.

So some context; I did recently move continents, but I switched all my devices to the new timezone so I figured it would not be an issue, and it wasn’t for about a week. Then it started not working, but because it wasn’t manifesting for the first few days I didn’t even consider it.

I guess I’ll keep this thread updated if anything else happens or if it needs to be reset again. Thanks for the help guys.

Update 1
Ran another impromptu test because I accidentally uninstalled the app, and it looks like the same thing happened again. It seems like the database only loads on the timezone you originally created it in.

1 Like

Thanks Alex for taking the time and reporting this issue. I was dealing with the same bug but didn’t have the time to report it in detail like you did. Thank you for that :pray:


For windows users - You can go to Settings>Time & Language>Date & Time

Make sure your second device match these settings from the first one.


Oh yeah, glad it worked out for you too. Interestingly enough, it doesn’t seem to matter what timezone my phone is on, It was only on Windows that it causes issues.