Changes to Relations are not saved upon restart

WHAT IS THE BUG

I’ve tried multiple times to edit Relations of Type “Object” to be linked to a specific Object Type to make it easier to select the correct Objects (of that Type). Unfortunately, after a restart, the

HOW TO REPRODUCE IT

  1. Locate an Object Type with the Relation you would like to change
  2. Ensure you change the “Selected object types”
  3. Create a new Object with this type and see that the Relation search results are properly filtered
  4. Close Anytype (Quit)
  5. Start Anytype
  6. Create another Object of the same Type
  7. See that the Relation filter is gone. Objects of all Types are shown again

THE EXPECTED BEHAVIOR

The change I made to be persistent across restarts.

SYSTEM INFORMATIONS

  • OS:
    Windows 11
  • Device:
    Dell XPS 15
  • Anytype Version:
    0.29.10-beta

ADDITIONAL CONTEXT

I have the feeling (but I cannot reproduce it yet) that the removal of Types also is not always persistent. I have already deleted the built in Task type once, and I had to do it again today.

Small update: indeed, changes to the Relations linked to an Object Type are not saved: upon restarting Anytype (Quit > Start) the default set of Relations is visible again.

1 Like

This seems to be for built in / default Object Types only, which limits the impact a bit :slight_smile:

Do you think they might be the same issue?

2 Likes

A post was merged into an existing topic: Object relations in templates reverts back to empty