Can't update Desktop 0.24 to 0.25

Describe the bug
When updating from within the app, the new version downloads successfully. On installation, message “Anytype cannot be closed. Please close it manually and click ‘Retry’ to continue.” appears. There’s nothing to close, so Retry doesn’t work, and no other option remains but to cancel the update.

To Reproduce
Steps to reproduce the behavior:

  1. Go to ‘Anytype → Check for updates’
  2. Click on ‘Update’
  3. Wait for the update to download and for the installation window to pop up.
  4. See an error

Expected behavior
Successful installation

System Information:

  • OS: Windows 11 Pro 21H2
  • Device Manufacturer/Model: Surface Book 2. i7 1.9GHz/8GB RAM
  • Anytype Version: 0.24.0

Additional context
Running the app as administrator prior to updating doesn’t solve the problem.

Hello @leobrien
welcome and thank you for the bug report.
I assume you checked the Task manager for any running process regarding Anytype?
Does it worked after a reboot?

The only Anytype-tagged process running was the update itself, so killing that just stops the update. A reboot didn’t help either, unfortunately.

Do the updates worked fine before that version? Or do you started with 0.24.0?

@Angelo What is the best way to gather information here?

I started at 0.24.0.

There is one more way for you to update to the latest version of the app, by uninstalling the current version and installing the latest one from the website. But if possible, Kindly wait until @Angelo responds so that the team can collect additional info if required for debugging the issue

2 Likes