Can't Login on Android

Describe the Bug

Just as a warning, I wanted to say that my use case is totally not the norm, and I’m pretty sure the issue is on my end, but I figured I should make a post anyway! Not sure if this should’ve gone into Support instead - please do let me know if I’ve posted in the wrong channel.

I’m using a custom Android ROM ([Lineage OS](https://www.lineageos.org/) 18.1) without [gapps](https://opengapps.org/). I tried logging in to my account using the app, but I’m getting stuck on the “Setting up the wallet…” page - at the bottom, in red text is “An error has occurred while starting account…”

To Reproduce

Steps to reproduce the behavior:

    1. Type in keychain.
    1. Hit login.

Expected Behavior

Log in to my account, with the homepage showing up.

Desktop:

  • OS: Lineage OS 18.1
  • Device: OnePlus 8 Pro
  • Version: 0.1.5

Additional Question

I took a look and noticed a few trackers on the app. I remember during the Zoom meeting it was mentioned that trackers were on the alpha and beta, but would be removed (?) in the final release - I wasn’t sure if that pertained to the desktop versions only, or if it covered mobile apps as well? Not a big deal either way, just curious!

@gabrielle Hi! Sorry for the long answer. Do you still have this problem?

Hi there! Sorry for the late reply on my behalf as well - I’ve just downloaded Version 0.1.6 and I’m happy to report it’s working - so excited! I was wondering if there were other ways of downloading the app besides through Firebase? While I’ve done it this time I wanted to delete my Google account for good and I don’t want to miss out on the newest releases.

@gabrielle Hi! We also distribute new app versions by Telegram. Are you a member of our Telegram channel?

@Kirill_Lem I am a member of the Telegram group - I think I must have missed the post with the newest release! Thanks so much for your quick reply :slight_smile: Looking forward to all the new releases, thanks for putting in all the hard work!

@gabrielle Are you a member of Anytype android test group or Anytype community?

@Kirill_Lem I’m a member of both! I think I just missed the message with the release - I don’t keep super up to date with the Telegram so I think I must have scrolled past it when I was going through the conversations :sweat_smile:

I faced the same issue yesterday with the 0.4.0-alpha version. The first time I logged in, An error occured while starting account is displayed along with the migration is taking place message both overlapped over each other. Restarting the app and logging in again worked. Oddly, I’m on LineageOS without any Gapps on an Oneplus device as well :astonished:

OS: Lineage 18.1
Device: Oneplus 5T
Anytype version: 0.4.0-alpha

Not having google services might be the reason for this message on the first startup but it would be great if the team could confirm this :grinning_face_with_smiling_eyes:

1 Like

I’ve also experienced this error message when setting up a fresh installation of Anytype 0.4.0. Interestingly, my phone is Google Play certified and has all Google services enabled (One UI 3.1, Android 11 November patch) , so perhaps this error is not strictly confined to devices without Gapps.

Luckily, restarting the app after the error message occured let me back into the Home screen, logged in with my account.

I got the same error message yesterday after a fresh install “An error has occurred while starting account…”

I then deleted ALL traces of Anytype on my smartphone (Android 11 with official apps) and reinstalled the v0.3.2 (302). After that I was able to connect to my account but this time it was as if I had just created an account, everything was empty and I did not even have my username on the dashboard.

It’s on the third try that I was able to recover my account, but since then the synchronization is not done anymore. It loads in a loop and even if I make a clean installation I have this problem every time.

I don’t know of any diagnostics to provide from the Android version.

--------- EDIT

Since then I’ve installed the v0.4.0 from a clean install, Everything was synced correctly.
But then I tried again a few clean install, and… I’m afraid that the “An error has occurred while starting account…” bug still occurs from time to time so it is not solved.