Can't create relation, Create button hidden by pop-up

WHAT IS THE BUG

Hello ! There seem to be a problem with the relation creation process. I have attached a video of the issue

HOW TO REPRODUCE IT

THE EXPECTED BEHAVIOR

Be able to create a relation from the relation panel of an object

SYSTEM INFORMATION

ᅟProvide your setup info:

e.g.

  • Dell laptop
  • OS:
    Windows 11
  • Anytype Version:
    v.0.32.3

ADDITIONAL CONTEXT

This happens in both minimized and full-screen views.
But, if I go to the type library and add a relation to the “type”, then this problem doesn’t occur.
I think the problem may be that Anytype is having problem with deciding how to display the content if the content goes outside the window.

I hope everyone is having a great day.
Thanks

It might sound stupid, but if you click next to the popup that on top of all others, won’t it close, making the Create button visible again? Similarly, if you select anything from the list, won’t the list close, making the button visible again?

You can just press the Esc key for now.

1 Like

Hi.
I understand what you are saying. I just tried again. But. when we make a relation to an object, we can choose to have a relation to any type of object or limit to one or more type of object, right? So, after selecting one type of object (in the new video below, :- note), the programme is waiting to see if I select any more type of object. Which is a good function. But, now I don’t have any place to click to get the create button back. Clicking next to the pop-up closes all the window, including the one with the create button on it. Just the “create new relation” pop-up remains.

This happens whether in the minimised or maximised window.
Hope this makes things clearer.
Thanks.

Hi!
Using the Esc button indeed works out. :+1:
Should I mark this topic as solved, or keep it open so that the team can work on it at a later date, mabe after things are not as busy as now, with the beta release and everything?
Thanks.

I think this is a bug, as it usually closes one window per click (which I found weird in the beginning because this is not the default behavior in most apps, but I like it now!).

See my recording here: when there is enough screen space, you can click on the same menu popup to make the other menus disappear, allowing you to click.

This means there are (at least) two workarounds:

  1. Use ESC to close the menus one by one until the Create button is visible,
  2. Make sure there is enough space on the screen, for example by maximizing the window and/or hiding the side bar so you can click on any visible part of the menu popup that contains the Create button.
1 Like

This report has been added to our issue tracker and received by the Development Team.

Hi again.
Yes, using the the Esc button closes the pop-ups one by one, like you and @andre mentioned. :+1:

Like I mentioned in my original post, when I try to create the relation by accessing the type library in full screen mode and adding a relation from there, (where there is enough space), then, like you said, this problem doesn’t occur.

  • Minimized in the type library - create button not visible

  • Maximized (full-screen) in the type library - create button visible

The problem is present in the following situations -

  • Creating a relation from the triangle relation icon, on the top right, of an object.
    • this happens whether the screen is in full-screen or minimized form
  • Creating an object from the type library with a small non full-screen sized window.

That is why, in the “additional info” section of my original post , I mentioned that I think the program is having trouble deciding how to display pop-up content when they go outside the app window, specially if the pop-up is near the top or bottom of the screen.

Sorry if this is a unclear. I know that the full public Beta release is the priority now. The team can decide when and how to deal with this issue. :slight_smile:
Thanks.

P.S - I also love how the pop-ups close one window at a time. This feels like a more granular approach to me. Some may say that it takes longer this way, but for me it helps me think. :blush:

1 Like

This happens to me a lot when working inside objects. I didn’t know about the esc trick, so attempting to click anything cancels the relation I’m creating. I always end up creating the relation without assigning the final step.

I think it’s interface related, the new pop-up shouldn’t show on top of an existing one.

Another related problem is that sometimes that pop-up is cut off when it shows up near the bottom of the screen. It should adjust itself upwards to accomodate the device’s screen dimensions.

I’m using Windows 10, 0.32.3

1 Like

This issue has been fixed by the Development Team and will be implemented in an upcoming release.

1 Like

Yay! thanks! This will be awesome and really help improve the overall experience, which is pretty good already, in my opinion.
have a good day.

1 Like