Can't create new object of Types created before 0.30.0

WHAT IS THE BUG

Since thee desktop upgrade, my previously created User Types no longer allow for the creation of additional objects.

HOW TO REPRODUCE IT

This is achieved either

  1. From the “Add new object” button on the home screen. Clicking this does nothing.
  2. Or going into my User Type and clicking the “Create” b utton and selecting “Object” as the option - nothing happens

THE EXPECTED BEHAVIOR

I should be able to create a new object for my User Type

SYSTEM INFORMATION

  • OS:
    Windows 11
  • Device:
    PC
  • Anytype Version:
    0.30.0

Hi @GHB,
you can delete the pencils from the template, they are just suggestions on where to write :wink:

I’m on the same version/OS as you and could not replicate the bug, do you happen to remember on what version you where before upgrading? Could you provide a video of the issue?

Hi

here is a link of the video demonstrating my bug.

My version prior to the upgrade was 0.29.1

1 Like

Thanks a lot for the video and details. I updated the title to better match your bug report. Can you confirm that this happens only with object Types created before 0.30.0?

1 Like

Yes, correct, it seems that for any User Defined Object Type I had previously created, I cannot create a new object for that.
Furthermore, on my home page, the “+” button is completely non-responsive.

1 Like

I have the same bug, i made a lot a custom object types last year and even the simplest object types that don’t have any relations fields cannot be created anymore. I am only able to create objects fr0m new types in the marketplace.

2 Likes

This report has been added to our issue tracker and received by the Development Team.

1 Like

Can anyone else reproduce this bug?

Works just fine in the latest pre-release version so I’m going to assume this fix will be shipped soon, maybe in a hotfix release.

There are at least two of us with this error. When is the date for the hotfix/ release?

I had tried several failed attempts to get this working, the solution which worked was to uninstall Anytype version 3, re-install version 29, and then upgrade to version 3 again. So far all seems to be fine - this ticket can be closed.

1 Like

Thanks for the update and your workaround, marking as solved and closing.