Cannot unmaximize the Anytype window anymore

The bug

Since the update v0.24.0 the Maximize/Unmaximize window button don’t work anymore.

It’s seems that I was able to maximize the Anytype window, but it is clearly impossible to Unmaximize it.

The window buttons were more and more buggy, but now it becomes totally disabling!

I’ve tried Double click, Dragging the window, but nothing works. And since Maximised screen acts like Full screen mode it makes this bug all the more disabling :pensive:

How to reproduce it

Steps to reproduce the behavior:

  1. Maximize the Anytype window.
  2. Then try to unmaximize.
  3. You can’t.

image

Expected behavior

I expect the Maximize/Unmaximize window button to work again. It was

System Information

  • OS: Window 10
  • Device: Personal Computer
  • Anytype Version: 0.24.0

Additional context

Related to but not the same as:

Minimize, Maximize, and Exit Buttons

Maximised screen acts like Full screen mode

Does clicking in the titlebar still works?

On Linux the maximize/unmaximize button are working fine.

1 Like

Nope it doesn’t, click, double click, dragging window, nothing works. :pensive:

It was a good question, thanks for asking :+1:t2:

worked for me on windows 10, both titlebar and icon, and titlebar logic didn’t change at all.

1 Like

there is Fullscreen button under WIndow menu, if you had fullscreen on prior to update you can exit it this way.

2 Likes

Thanks a lot!

I had not seen or used this menu before. But as you say, I must have been in fullscreen before, mainly because prior to this update, the maximized windows went straight to fullscreen mode.

exactly so, this is why it got reworked, since on windows this middle button has a bit different functionality, the menu was absent before, I’ve added it in this patch.

1 Like

So you solved:
ㅤㅤMaximised screen acts like Full screen mode
ㅤ+ Can't move Anytype application window
ㅤ+ [UI] [Windows] App doesn't resize to small from fullscreen mode if I drag it away
At the same time ! So yes the titlebar logic change quite a lot and it’s a big relief :pray:t2:

But can you explain what is this “Zoom” view on your window menu? I don’t see any change when I use it :thinking:

It’s coming from default menu, maybe it’s screen zoom, I’m not a windows user myself =) If it is, I will look into docs to enable it.

I never seen anything like that before in an software window menu, but since it does absolutely nothing, it should probably be removed.