Cannot select account on iphone with qr code

WHAT IS THE BUG

Trying to login to iPhone app with QR code or passphrase isn’t working. Displays error message: “Select account error”.

HOW TO REPRODUCE IT

  1. Migrated desktop to 0.33.0
  2. Copy & pasted some objects with edits from the Alpha iOS app to desktop 0.33.0
  3. Installed iOS 0.23.2 (tested both Test Flight and App Store)
  4. Scanned QR code, correctly inputs recovery phrase- “Select account error” after about 30 second load time.
  5. Manually input recovery phrase- “Select account error” after about 30 second load time.
  6. Sign in with keychain- “Select account error” after about 30 second load time.

THE EXPECTED BEHAVIOUR

Log in and sync.

SYSTEM INFORMATION

  • Device:
    iPhone 12 mini
    (M1 MacBook Pro)
  • OS:
    iOS 16.6
    (MacOS Ventura 13.4.1)
  • Anytype Version:
    v.0.23.2 (1) on TestFlight and
    First App Store version

Update: I am now successfully logged in!

@here
Is anyone here still having issues with the QR code in the latest version?

The problem still exists. Installed Anytype 0.37.3 yesterday for the first time on MacOS Ventura 13.5. Installed Anytype 0.27.0 on iOS 17.1.2 today.

“Scan QR code” on iOS says “Error select account”. Using recovery phrase just crashes the iOS Anytype right to the iOS home screen.

Both devices are on the same LAN, Anytype on MacOS has the green “synced” mark and on hovering says “Backed up on one node at least”.

Also note that entering the recovery phrase in iOS is problematic - the cursor jumps to the end every time a letter is typed. Very hard and confusing to fix typos that are longer than one character.

Update:

Turns out the QR codes in “Tasks → Experience Anytype on your mobile devices or desktop” and “Anytype → Settings → Account → Recovery Phrase” differ.

Scanning the code under Settings crashed the iOS app for the first scan. But the second time succeeded.

1 Like

January 17, 2024

I am a new user. I have freshly installed Version 0.37.3 from the webpage and the current version from the app store.

I switched to local-only mode at the main dialogue (gear top right) and then created a new user on my Mac. After initializing the workspace, I attempted to connect my iPhone via QR scan.

Encountering the first error, “Select Account error,” I resolved it by navigating back to the main screen on the iPhone, selecting the gear icon at the top right, and choosing “local only.”

However, I encountered a second error when the iPhone asked for permission to scan the local network. After granting permission, the three dots on the former login button started rotating and have been doing so for the past 10 minutes, with the iPhone becoming hot.

Any fix or idea for a workaround?

Edit: My Win 10 Desktop in the same network were paired effortlessly,

Edit 2: Now it works. I entered the phrase manually and now it worked.

1 Like